SONG PLAYBACK IS MUDDY HELP!!!


(THEXP7R) #1

every time i preview a song or load it to edit sample cut copy paste ect.

the playbackof the bass itself sounds very muddy or seems

to loose its quality over time why the heck is it even doing that???


(Zer0 Fly) #2

please be more specific about what you do to experince the problem. like you describe we can only guess…

you render to sample, edit, and replay and render, and with each rendering step the quality gets worse?

maybe you render through effects like exciter or limiter which will f.up your sound with every time you rerender it?


(THEXP7R) #3

every time i preview a song or load it in Sampler

the playback is a lower quality then the actual

song using any other program

the bass becomes very bit crunchy

and orloosesquality to the point of

muddily bassline it just sounds wrong

what settings do i need

to tinker with

to restore the quality at least towards

its original or better quality??

please be more specific about what you do to experince the problem. like you describe we can only guess…

you render to sample, edit, and replay and render, and with each rendering step the quality gets worse?

maybe you render through effects like exciter or limiter which will f.up your sound with every time you rerender it?

every time i preview a song or load it in Sampler

the playback is a lower quality then the actual

song using any other program

the bass becomes very bit crunchy

and orloosesquality to the point of

muddily bassline it just sounds wrong

what settings do i need

to tinker with

to restore the quality??


(dblue) #4

The default track headroom setting in Renoise is -6dB, meaning that imported samples will play a little bit quieter by default, which can be more noticeable compared to your external media player or some other app that may be fully normalised to 100% volume at 0dB.

However, there should be no measurable difference in the actual “sound quality” of the Renoise output, it just sounds a bit different due to the slightly lower volume.

You’re simply used to hearing things playing a little louder, which will naturally seem to reveal more details within the sound or make it seem “higher quality”.

Render your song, normalise it back to 100% volume, then play it back elsewhere and it should be fine.

If you are noticing a change over time while working on your song, then I bet it’s due to Renoise’s master volume level auto-adjusting itself lower to prevent loud sounds from clipping.

You can enable/disable this auto-levelling feature right beside the master volume slider:

http://tutorials.renoise.com/wiki/Main_Screen#Upper_Status_Bar

The -6dB track headroom is there to help prevent multiple sounds from clipping the master output, but you can also disable or change the headroom if you really want to:

http://tutorials.renoise.com/wiki/Song_Settings


(GUEST:::El°HYM) #5

Agree…seems 2B the good old -6db #headroom - prob.


(ffx) #6

Eyegreed. Maybe he replays a 8 bit sample or disabled interpolation? Or a audio driver problem? A fixed hardware output sample rate? Maybe even a psychological side effect.


(THEXP7R) #7

The default track headroom setting in Renoise is -6dB, meaning that imported samples will play a little bit quieter by default, which can be more noticeable compared to your external media player or some other app that may be fully normalised to 100% volume at 0dB.

However, there should be no measurable difference in the actual “sound quality” of the Renoise output, it just sounds a bit different due to the slightly lower volume.

You’re simply used to hearing things playing a little louder, which will naturally seem to reveal more details within the sound or make it seem “higher quality”.

Render your song, normalise it back to 100% volume, then play it back elsewhere and it should be fine.

If you are noticing a change over time while working on your song, then I bet it’s due to Renoise’s master volume level auto-adjusting itself lower to prevent loud sounds from clipping.

You can enable/disable this auto-levelling feature right beside the master volume slider:

http://tutorials.renoise.com/wiki/Main_Screen#Upper_Status_Bar

The -6dB track headroom is there to help prevent multiple sounds from clipping the master output, but you can also disable or change the headroom if you really want to:

http://tutorials.renoise.com/wiki/Song_Settings

no its literally my sound QUALITY not Volume

it becomes that grainy/bitcrunchytype of bass sound

when highquality basslines emit from any song

are put into Sampler to edit or when i attempt

to master

im forgetting how to tamper with it to

align it to clean smooth it out what

should i use to do so?


(GUEST:::El°HYM) #8

Move away from #flatearth as acoustics can seem pretty creepy in that realm.

no its literally my sound QUALITY not Volume

it becomes that grainy/bitcrunchytype of bass sound

when highquality basslines emit from any song

are put into Sampler to edit or when i attempt

to master

im forgetting how to tamper with it to

align it to clean smooth it out what

should i use to do so?


(danoise) #9

it becomes that grainy/bitcrunchytype of bass sound
when highquality basslines emit from any song are put into Sampler

How do you obtain the sample - are you rendering the snippets from the song using Renoise, or using some plugin to capture the audio?
You also mentioned “previewing” the song - I’m not sure what you’re referring to here.

Rendering from Renoise is done using the playback settings of the song, with 32-bit float precision and should be virtually indistinguishable from what is played back.
You can render the whole song too, which gives you additional control over these parameters - but it doesn’t seem this is the case here.


(dblue) #10

no its literally my sound QUALITY not Volume
it becomes that grainy/bitcrunchytype of bass sound

If the problem is easy to recreate, then could you please upload a small example for us to listen to?

Please upload a small clip of the original sound before you’ve imported it into Renoise, so we can hear its original quality.

Then upload a small Renoise XRNS song that includes the lofi or distorted sound you’re describing, so we can hear the difference in quality.

Double check all your audio settings in Renoise to make sure they’re correct.

http://tutorials.renoise.com/wiki/Preferences#Audio


(EatMe) #11

every time i preview a song or load it to edit sample cut copy paste ect.

the playbackof the bass itself sounds very muddy or seems

to loose its quality over time why the heck is it even doing that???

perhaps the imported sample is at a higher bitrate or frequency than the actual Renoise playback bitrate; soundcard bitrate and frequency?

When importing a sample, the bitrate and frequency can be seen in the top part in the Sampler window , next to the Adjust button ,

with that Adjust button the sample bitrate and frequency can be resampled to match the playback or soundcard bitrate and frequency.

Playing back a sample from a higher bitrate or frequency at a lower bitrate or frequency will generate artifacts, as described in the original question.