Song render to disk issue with ADAT

Hi,

I am using my Behringer UMC 1820 as an ADAT interface for my Yamaha O2R mixing desk, sending various mix channels out to the desk, via ADAT out 1-8, and returning any outboard gear back through the desk (either stereo out or bus 1 and 2) into a line input, using ADAT in 1 & 2 in Renoise.

The mix channel receives the Line Input, but something funny happens when trying to render the output to disk.

The ADAT outputs switch to Out 1/2, so whilst they are output to disk, it means the ADAT input path is the wrong level, and so are the renoise output channels! :crazy_face:

I have attached a gif of the issue, so you can see it swap over. Is this a bug, or is there something I need to set somewhere? I have checked other posts but they don’t reflect my issue, and are from a long time ago, so things may have since changed. :slight_smile:

As requested in the sticky post:

Issue

Outputs switching when trying to render song to disk

Steps to Reproduce

  1. Open Renoise
  2. Set a few tracks to output to ADAT
  3. Assign a #Line-in component to an empty track, and assign its INPUT to ADAT in, using Live recording mode, and assign its OUTPUT to Master
  4. Go to File → Render song to disk
  5. Choose RealTime render

Expected Result

Only the ADAT Input channel is recorded as it is fed through to the Master output, as the others are set to ADAT out.

Actual Result

All Renoise mix channels that were set to ADAT out are switched to Out 1/2, so the output from the Mixing desk isn’t replicated in the generated wav file. Renoise Mix channels switch back to ADAT output when complete.

Definitely an edge case usage, I know, but hoping you can help, as I’m really enjoying using a tracker again after many years without Octamed :frowning:

RenoiseExportIssue_20240409

Thanks in advance, and thanks for an awesome application! :slight_smile:

1 Like

Strange how the ‘Outputs change’ when you hit ‘Render’.
It might be helpful if you could post your Audio Preferences page.

yeah, tickled me a bit! :smiley:

Here are my preferences:

My audio interface is set to ADAT mode for the optical connections.

Hope this helps, and thanks.

Whelp, found a workaround!

Not elegant, but involves the following:

  1. Audacity
  2. LoopBeAudio
  3. VB Audio Matrix

LoopBeAudio is just setup to lock to the shared format (not sure it does anything, but works).

VB audio matrix is awesome. Took some messing about, but just needed to route the two ins to an out, which then maps to the loopbe in and outs. Also mapped my Bluetooth headphones so I can monitor the PC :slight_smile:

The routing grid is trickier, as it truncates most of the source/input names, but as long as you remember to assign left and right seperately, all good.

Finally set Audacity to WASAPI, pointing to the LoopBeAudio ins and outs, and we’re ready to record :slight_smile:

Screenshot for headache :smiley:

Might help other people in a similar situation, but obviously if we could find a way not to switch the audio routes when rendering, that would be even better.

Thanks

1 Like

Just seeing if anyone found out why the audio switches.

Is there a way to get renoise to output logfiles?

Thanks :blush:

We may need a developer to provide some feedback as to why the audio switches.
Curious; does this still ocurr if you select “DirectSound” for the ‘Device type’?

No, but then that is no good for me anyway, as it won’t allow me to access the ADAT ins and outs :slight_smile:

Including others for further guidance. @dblue @taktik
OP is a first time poster with a seemingly interesting issue; is there something we are missing?

Why do the outputs change when hitting render, but otherwise plays ‘ok’?
Could ASIO4ALL help here?

TIA