Sound crackles at/above 30% CPU usage

All of a sudden I get sound crackles when using Renoise in 1080p resolution. Never happened before. It seems like it occurs when the CPU goes above 29-30% usage. Below that there are no crackles.

CPU: I7-10700K
GPU: RTX1060
32Gb Ram
Windows 10
Latest Renoise
Focusrite USB ASIO

Does it help when you reduce the used CPU cores in preferences?

I had such issues with hyperthreading and some plugins and low latency setup (between 2 and 3ms)… Maybe there’s something to sort out between your buffer settings and overall computer performance. (for now, HT is disabled here :slight_smile: )

If using the ASIO driver, try increasing the buffer size, because it might be set too low or the setting has been reset after an update.

Maybe try this, but set to background processes:

1 Like

On Linux when this happens…I know I have to disable CPU frequency scaling…like setting the cpu into performance mode, so it is clocking full throttle all the time. Else the clocking up and down can sometimes cause trouble with realtime audio. Like when a core hits a certain load, so it would get clocked up to be able to take more load, it could create crackles, and audio will change load up and down all the time, causing the cpu to switch all the time. But only when the powersaving frequencies are no longer enough to render the audio…hence it mostly starts at 20-40% load…

I’m getting a slight crackling sometimes when saving the track while it’s playing (Ubuntu 20.4)This seems to happen in larger projects only.

There it is:

lilith: I tried to reduce used CPU cores - no difference.

TheDamnChicken: I tried to change the ASIO buffer size - helped a bit. Less noticable crackles, but it’s still there or maybe it’s just my imagination.

ffx: Tried changing to “Background services” - no difference. Will try the FlexAsio later.

This ableton help topic talks about how to do on windows what I do on linux:

Maybe you can try and see if things get better? What latency have you set in the preferences?