Space as Stop/Edit keys

I am used to the “old way” of stop song/edit toggle (spacebar), as well as right CTRL key for playing song.
You know, the way it used to be and we all loved it! (Now it’s like ESC key, or Enter, or whatever. Silly stuff.)

I am having problems setting this up in new versions. It’s not apparent to me how to get it to actually work that way again.
Any tips?

Anders aka PsychoFreud


4498 renoise-psychofreud-keys.png

Ok, but … doesn’t really do anything for me in v3.0beta.
Space has absolutely no function, doesn’t matter what I change that setting to (Renoise or FT2 mode). ESC seems to still be active for edit toggle.

RControl works.

Really? Huh. It works just fine here on Windows 8.

In FT2 mode, spacebar will stop the song if it’s playing. If the song is stopped, then it will toggle edit mode.

I wonder what could be clashing on your system.

Maybe if you manually unbind spacebar in the key prefs? I think it’s mapped to Play/Stop/Edit by default. Maybe that’s getting in the way somehow.

I don’t know. I have Win 8.1, running Renoise 3 beta3.
If I press spacebar while a song is playing, nothing happens (have to press Enter). If nothing plays, no edit mode (have to press ESC).
I toggle the setting back and forth but nothing really happens.

Edit: in fact, Enter key now has the function I am after for my spacebar. It stops, and edit toggles.

That field had “Enter” in it. I removed it and put in “Space”, and with the FT2 setting on, it now works. Thanks!