Spectrasonics Vst Crashes When Loading A Track I Just Started In B6

Gives error msg:

UVI engine erroe
An error occured.
The .dat file is not the right version. Please contact your dealer.
Error ID : 30001

Also got Error ID : 32 once

And then after that I get:

Fatal VST Plugin Error
Ouch. The VST plugin ’ (from )’ crashed in VST event/function: ‘Dispatch’, Thread: ‘GUI’

Seems to be Native Instruments Pro-53 that’s causing it, since I lastly get a message that that couldn’t be loaded.

It only crashed the first couple of times I tried to open the track though, now no more crashing and the track opens with everything there except the Pro-53

‘Uvi Engine’ is related to spectrasonic plugins. Try reinstalling it or disabling it please.

Hm right… I removed the pro-53 and saved under new name, and then it came up with couldn’t open trilogy instead, but by then i just gave up. Will disable it and get back to you

Okey. I reloaded the original track i was talking about, removed Trilogy, saved under new name and reloaded it. Still can’t find pro-53 for some reason, and the other vst’s just give me a grey window, no GUI.

Then closed Renoise, restarted and reloaded track, “A fatal error or crash occurred (unhandled exception in thread: GUI)”.

Closed, reopened, “Ouch. The VST plugin ’ (from )’ crashed in VST event/function: ‘Dispatch’, Thread: ‘GUI’”

Now I can’t open the track at all anymore, it crashes every time i load it so far…

The other vst’s in the track were Nepheton and Albino, and I’ll be honest, they are pirated. But, everything was working fine in b6…

Edit: The crash-autosave suddenly loaded. Removed the pro-53. Settings were back to default on albino, but could see it and change settings, then got a gui error that messed up half the albino’s gui. Nepheton gui won’t show. Also have a CS-80V in here that doesn’t show the top of it’s gui.

Reloaded latest “real” save, removed the pro-53, saved, reloaded. No errors loading. Right settings on albino. Still won’t show Nepheton, still top of cs-80v missing. Both sound right though. Albino gave a “Ouch. GUI” error after fiddling a bit with it.
Curious thing, while leaving that error msg open and trying to edit my post the forum here got all messed up, I suddenly only saw the first letters of a couple lines of this post while trying to edit (started editing it before this happened, I’m retyping everything now since i had to reload the page after closing the error msg). Maybe it’s something to do with my comp…

Anyways, now, without trilogy and pro-53, it loads, nepheton has no gui, albino gui at first but open 2 of it then Ouch. Cs-80v some of the gui is missing.

Made a new track in b7 with pro-53 and trilogy, no problems…

It seems this song got completely berserk after all those crashes. If the song is important to you, send it to us and we’ll see what we can recover please. I think that’s all we can do here?

Nah, song isn’t really important, but thanks anyway. I just figured the report might be helpful to you in some way.
Everything seems to be working fine in b7 so far.

It seems I was a little too quick with stating everything was working fine in b7…

Now, when i reloaded the track i was working on yesterday, i’m still having massive gui-troubles, some vst’s will show some of their gui, some won’t show anything at all, just a grey window. I can still click randomly and stuff will happen as if the gui was still there, but i can’t see wth i’m doing.

I’ve tried reinstalling, starting new track, adding some vst’s, saving closing and reopening, same problem.

At this point it seems b7 is unusable to me. Am I the only one having this problem?

Would you mind sharing this song, so that we can have a look at it?

Also is this a 64bit Renoise and the plugins are all 32bit or all 64 or 32bit?

Will share it later today, not at home right now.

It’s all 32-bit (win xp 32-bit, renoise 32-bit, vst’s 32-bit)

Files were too big for the forum, so i found a site and uploaded there. Hopefully it’s legit and working, never used it before.

Uploaded a zip-file with both tracks in it.

EreiraNr6_3 is the one i talked about that i started in b6
TheOther2_3 is the one i started in b7


Thanks for looking into it, hope you can figure something out.

Maybe worth mentioning, it seemed like the gui error kind of rubbed off on other stuff yesterday, when i had renoise open with a track with grey ui’s and all, I couldn’t get focus on the editor here on the forum and write a post, it refused to work untill i shut down renoise. Weird stuff.

Hello CeeRo,

Don’t have most of the plugins used in EreiraNr6_3, but all from TheOther2_3 so I could only test this one.

The song file “seems” fine. Nothing obviously fishy I could notice. Also could not replicate the GUI errors in the plugins you’ve mentioned.
How/when exactly do you get them? Does this now always happen to you when loading up one of the songs and opening one of the plugin GUIs?

I’ve also noticed you are using a multi monitor setup. Probably this is somehow related. If you disable the second monitor, does things then work fine?
There are is a related option in Renoises GUI preferences -> “More compatible GFX updates” which fixes troubles with some drivers in multi monitor setups. This should only affect Renoise itself and not plugins though.

Are you running Renoise in fullscreen mode?

Could you please also attach/send us the Renoise log file? Click on “Help” -> “Show Log file…” to locate it.

Probably someone else could also check if those songs behave strangely on another setup?

Everything has been working fine yesterday and so far today, thank god :)

If something messes up again I’ll run through your list and keep you posted.

Attaching the log file just incase you can get something out of it