Spontaneous plugin incompatibility?


Alright, so this is a weird one. Just this last November I upgraded to 3.3.2, and up until very recently I had no problems whatsoever with it. Then about two days ago, while trying to boot up a track I’d been working on since then, I get this message for several Valhalla DSP plugins I had in my sends:

Screen Shot 2022-01-26 at 10.35.41 AM

I know it’s not an issue with the plugins themselves, though, as they’ll even boot up in Audacity without any problems. Furthermore, even .component (AU) versions of these and other plugins fail to initialize, despite the directories being configured exactly how they should. In chronological order, I’ve tried to:

  1. Restart Renoise and perform manual scan
  2. Restart computer
  3. Manually edit plugin directories (and then revert them to default)
  4. Reinstall all Valhalla DSP plugins (.vst/.vst3/.component)
  5. Reinstall Renoise from freshly downloaded .tar file
  6. Manually delete all caches through preference folder, un- and reinstall Renoise from an even fresher .tar file
  7. Look through config.xml file (Renoise actually showed connectivity to the directories)

For added context, this is a 64-bit copy of Renoise I’m running on a MacBook with macOS Sierra 10.12.6 and an Intel i5. I’ve had Renoise on here in one iteration or another since 2017, and never had any major compatibility issues like this come up. As it stands right now, Renoise won’t initialize plugins of any kind, and most won’t even show up after a scan.

Thanks in advance!

Did you update Valhalla plugins itself? The vendors sometimes change the executable name without changing the identifier, and Renoise sadly uses the executable name as identifier (only for vst2 macos). Happened quite a lot with TAL and Softube plugins, too.

You can fix the song then by editing the song.xml. Also make sure you really updated the plugin database.

TLDR: Try to switch every plugin in your song to the VST3 version.

The Valhalla plugins are completely up-to-date after reinstalling them, but they stopped communicating with Renoise before that. Also there doesn’t appear to be any difference between the identifier and the executable. Based on the log, it looks like Renoise is finding the plugins but failing to load the executable and generate a unique ID.

unpack the old plugins in one dedicated folder (in renoise vst path) and unpack also the new plugins (in renoise vst path)…rescan…load your track…

Hey guys! I Have this same problem with MacOS Sierra, Renoise 3.2.2 and Supermassive now. I ran the Device support update recently and after that I have kept getting a message: “Failed to initialize the plugin ‘VST: Valhalla DSP, LLC: ValhallaSupermassive’.”. I’ve tried to reinstall the plugin and rescan the directories, but that doesn’t seem to help.

Any ideas how to fix this?

Thanks in advance!