SSL Native Bus Compressor 2 (CPU/sandbox)

I think this is a buggy plugin as it lights up all my CPU cores in all DAWs tested.

Anyway here are my issues with it in Renoise:

  1. Edit: Make sure “Run all plugins in sandboxes” is turned on in preferences.
    If it’s not then turn it on and quit Renoise as it has to be turned on initially

  2. Open Renoise, 1% CPU usage is shown in both Renoise and Task manager.

  3. Add SSL Native Bus Compressor 2 (either VST or VST3) and Renoise still appear to be using 1% CPU at the top right corner but in Task Manager CPU usage jumps to 25%. Keyboard is still responding fine though.

  4. Open the SSL plugin GUI and close it, then the system gets sluggish and keypresses hangs or repeats for a second longer than it should when you hold a key down for a bit, ie. if you press an arrow key it will keep moving after you have released the key.

  5. Remove the plugin and the cursor/system gets back to being responsive.

  6. Another thing worth mentioning is that I had Sandboxing enabled to be able to use Soundtoys effectrack, if I add the SSL compressor and then turn off sandboxing then even though I open and close the plugin the cursor is still properly responsive. It still works as it should if I turn sandboxing back on.

  7. IF “Run all plugins in sandboxes” is turned OFF and I remove the plugin then the CPU meter in Task Manager stays high at 25% despite the plugin should be removed.
    If "“Run all plugins sandboxes” is turned ON then the CPU usage correctly goes down.

I’m on a i5-9600k (6 cores) CPU, Win10 pro 22H2, 16GB RAM.

Why is Renoise showing 1% CPU use and Task manager ~25% and why does it stay at 25% even after removing the plugin? (Ableton Live, Reaper does it too on my system)

Why is Renoise repeating keys after opening and closing the plugin GUI even when it’s run in a sandbox?

1 Like

I have none of these, I’ve used the bus compressor for a few years without any problems, just tested with and without sandboxing and I noticed no difference in cpu use with the vst3 and latest renoise

Thanks for checking it out.

Edit: I don’t know what’s causing this, even without the sandbox the plugin spikes the CPU usage in task manager to 25% which is abnormally high, then when I on top of that use the sandbox it’s apparently too much :thinking: could it be that I have no hyperthreading on the CPU? or is it time to reinstall windows :tired_face:

First I would test if it is working in e.g. Reaper.

Good idea… Here are results from my installed DAWs:

It’s working in Reaper. I tried in all four “bridging/firewalling” compatibility options.

It’s working in Ableton Live 11, I couldn’t find a sandboxing option there though.

It appears to work in Cakewalk but the SSL compressor GUI is not smooth, I think if this had a sandbox feature like Renoise then I bet it would do the same.

The CPU shoots up to about 20-25% usage in task manager for all DAWs which I find hard to believe it should :face_with_diagonal_mouth:

I noticed something new, I opened Intel Extreme Tuning Utility and saw that whenever I insert the SSL Native bus compressor 2 the Active Core count is consistently using all my 6 cores unlike other plugins that fluctuate between 1-6 cores.

It appear it doesn’t like my CPU!?

1 Like

It’s only shown in the Task Manager.
Both VST2 and VST3 use 20% each on my i5-9600k CPU.

Only VST3 version in a blank song.

Both VST2 and VST3 versions in a blank song

And when removing both plugins CPU usage stays this high as if they weren’t removed.

And oddly if I add more the CPU use doesn’t go up, I tried adding 10 instances and CPU use didn’t really go up.


Yes I did check also that but there was no real difference

Thanks for checking.

Gotta be some Windows crap going on. F^&K!

Resurrecting this thread to report that I’m having exactly the same issue, but with all of the SSL plugins I have: Bus Comp 2, Channel Strip 2, FlexVerb, Vocalstrip, X-EQ2, X-Saturator v6 and X-ValveComp v6.

It seems to be something to do with how SSL are rendering their GUIs. When the SSL GUI is open, then no problem. But if you close the GUI, then renoise slows down drastically - especially the keyboard input. It becomes so laggy with so much key repeat (i.e. if you hold down a key and then let go, it takes some time for all the key presses to clear), renoise’s interface becomes basically unusable until you remove the SSL plugin.

I’m on a Windows 10 machine running a Core i7-7700 CPU @ 3.60GHz with 16GB RAM. All other renoise settings are the same as @Garf above.

I mean, the workaround is to just not use SSL plugins at all… but this is all very strange. Never experienced anything like this with Renoise and any other plugins.

You really should report these issues to SSL, I don’t think there is much Taktik can do about it… Maybe the order how stuff is destructed is different in Renoise?

Or could it be a copyprotection service running in the background? A lot of “major brand” plugins also are hammering the internet while usage (and don’t accept a “no”). Are you blocking the outgoing internet connections for your DAW?

1 Like

Sorry i forgot to update this thread…

Back then i contacted SSL and I made them aware about this behaviour, I also told them the behaviour was known from their other plugins so eventually they updated the Native bus comp 2 and I haven’t had an issue since.

Are you running latest updates? I believe Native bus comp 2 v1.3.4 shouldn’t behave like this anymore but your other plugins might need them to fix it.
Edit: Somewhere on SSL’s website they have release notes where you can see they fixed this issue in v1.3.4 but it’s hidden away and they also have an old release note list polluting their site so I can’t find it right now but you should be able to find it with a bit of luck.

Try Google for the issue and you’ll find others having similar issues fixed and then contact SSL with links.
Edit: I don’t know what’s happening to Google’s search engine but I couldn’t find the links I found last time :thinking:

1 Like

Ah cool ok I’ll try updating. I was pretty sure that I was using the latest versions when I tested the above, but will try updating regardless and see what happens.

Yeah I wasn’t expecting @taktik to have a solution for this because it’s clearly not a renoise problem. Renoise has been so solid over the past decade I’ve been using it. Probably the most stable software I have ever used for anything :sunglasses: But I wanted to report it here in this thread anyway to exchange info about solutions and workarounds.

SSL plugs use Ilok IIRC so potentially that also be something to investigate. Good point!