Strange Cpu Overload With Glitch Plugin

there is a particular fragment of one song I have where the CPU reaches 50%. It’s very strange since there aren’t heavy vst or anything else. It seems it’s the Glitch plugin causing it, but I’m surprised since I’m using it in many other songs. Sometimes even more than one, with no problem.

I’m attaching the file. I played the song on two computers: one laptop with windows xp and a desktop with windows 7 64 bit. The problem it’s the same (but the laptop crashes).

Any suggestion?

If you suspected Glitch, then why not contact me directly instead of posting here on the Renoise forum where I might not ever see the message? :)

Anyway, it’s definitely something weird happening with Glitch. Seems that it doesn’t like processing this long block of silence with none of its effects running. If you’ve got these long periods of time in your song where you’re not actually using Glitch for anything, then it’s probably better to actually disable the VST during those times. Enable the effect when you need it with xF01 (where x is the number of the effect in the DSP chain), and then disable it with xF00 when you don’t need it.

I don’t think everybody realises you are actually Glitch’s programmer :lol:

Sorry, you’re right. It’s just that I suspected it was glitch while I was writing this message. So then I didn’t think of contacting directly you.

Ok, thanks.