Strange Note On/off Clicks With Custom made Vsti


i have a strange effect with renoise using my own vstis.
when i load the plugins and just play notes everything sounds fine as it should.
when i record some notes they still sound fine while recording.

when the pattern is played back, the already recorded notes produce some severe destortion when the note starts and when the note stops. and while the already recorded notes have those clicks, the new notes added again sound fine until they are played back by renoise …

iirc this distortion happens in any renoise version since 1.5.2 and the very same plugins sound fine up to renoise 1.5.2 and in other host applications like Madtracker

any hints or ideas?



what vsti? you say your own, do you mean you programmed them and aren’t to be found online? If so, we can’t check if your problem is ‘universal’. Does the rest of the song play fine / samples etc, so this aint a latency/soundcard setting thing?

yes, i coded them myself and you can find one of them here for testing

just apply the vsti to an instrument and hit some keys (should sound like a sine with some delay) and the sound should be ok and without distortion.

record some notes, it should still sound ok.

play back the recorded notes and it should produce these distortions/clicks at note on and note off.


Sounds as if your plugin has a problem with polyphony while making use of the delta frame field in the VST event structures (we starting using those in Renoise 1.2.Something). Maybe that’s the reason why this doesn’t happen with Renoise 1.5.1 and with Madtracker.

As you are the developer of the plug, couldn’t you try to find out what exactly happens in your plugin? Its very unlikely that this is a Renoise problem. Thousands of VSTi just work fine in Renoise…

the effect has nothing to do with the polyphony settings, as the distortions also happen when you play a single note.

apart from that i’m using delta frames. in the processevents method i gather all events for the upcoming frame and store them in a vector. in the process/processReplacing method i do trigger the synth until the first event is due, then update according to the event information, then process the synth until the next event is due …
so basically i dont see anything wrong here.

i dont claim that its not my fault, but i find it strange that until version 1.5.2 it worked fine, as it also does in madtracker.

and what irritates me even more is that it sounds fine when the notes dont come from the pattern playback but are played with the keyboard directly.

so basically i’d be interested where the difference is between hitting notes on the keyboard or getting notes triggered by the pattern, since this is my one and only problem.

In Renoise 1.9 it also crackles here when live playing notes, so this doesn’t make a difference here.

Also the crackles seem to come from the Note Offs. Try a simple pattern like this:


And the plugin crashes here (only tested on Win Vista) when releasing the library. Would be great if you could take a look at this as well (if thats somehow our fault)…

i tested in renoise, reaper, eXT2, Aodix, Buzz (polac’s vst loader) and Fl studio.

played: 1
rendered: 0

played: 0
rendered: 0

played: 1
rendered: 0

played: 1
rendered: 0

played: 1
rendered (only RT-recording) : 1

played: 1
rendered: 1

i played with the ppq setting (default: 192) in Aodix and i get the impression that when lower the ppq (EDIT: 96) the synth becomes more smooth.

dunno im no Dev but it looks like (via GUI -> activated voices) the sound is clipping when a voice is released.

btw: what a nice synth!

will try it with 1.9 tonight and i’ll check the signal in the output buffers too.

according the vista deinit crash, i cannot check that since i dont have vista and basically i dont care about that platform :) with xp i didnt have such crashes up to now and the plugin is for internal use only atm so its not really important for me.

thanks anyway


the activated voices display is more a hint than anything else. its updated on a very low frequency (10 times / s), but i dont think its a clipping artefact because the synth either puts out a zero signal or a signal in the range [-1,1]. but as said before, i’ll check the buffers tonight and try to find out whats happening there.

thanks :)

well ok … apparently it was my fault.

strange enough that this bug survived in the basecode for 3 years and i never really noticed it.
i did in fact use the deltaframes information to process the events at the right time but i forgot to offset the output buffers accordingly… :rolleyes:

now it works smooth.

please update that download link! :slight_smile:

download link should be up to date with the fixed version now.