Sylenth crashes at render

Hi guys

I have sylenth 1 v3.067 (latest) and renoise 3.3.2
i use sandbox option and everytime i want to render a sylenth track it says “renoise audio plugin server has stopped working” so it renders all the track except the sylenth, it s perfectly reproductible, a new project with a note of sylenth init preset, sylenth process will crash at render, it did not do that with previous version of sylenth though… I asked to lennar, they don’t really understand the problem. Do you have any idea?

edit: It crashes ONLY at render, playback and tweaking are perfectly fine

I have same versions on Win10 and can’t reproduce this :thinking:

what render options are you using? Does changing to an alternative work without crashing?

i tried every render option… all interpolations

i have win 7 unfortunatly

What does Renoises log file say? Perhaps more info there?

the thing is that renoise does not crashes, just sylenth crashes, the rest of the project and software is unafected so it does not generates a crash log

I thought there was an audio server log.txt file generated even if you are running the plugin using the server sandbox(?)…anyways does it crash if you don’t run the plugin in a sandbox?

I think this also generates something in the .log file?

GUI: Creating the Document GUI…
GUI: Successfully constructed

Application: Successfully loaded ‘cavalcade 2021.xrns’.

RenderToDisk: Prepare rendering with mode:‘Selection in Sequence’, separate tracks:‘NO’…
RenderToDisk: Validating render options…
RenderToDisk: Resetting the player…
RenderToDisk: Preparing the audio files (1 in total)…
RenderToDisk: Killing Audio IO…

ASIO: Stop Polling…
ASIO: Releasing Solid State Logic ASIO Driver…

RenderToDisk: Rendering at 44100Hz with a block size of 2048 samples…
RenderToDisk: Setup track routing…
RenderToDisk: Entering the render thread…
RenderToDisk: Preparing latency compensation: Will shift all content by 2619 samples…
RenderToDisk: Starting to render…

Error Message: Ouch. The plugin ‘LennarDigital: Sylenth1’ in instrument 0F crashed, or is no longer responding.
Error Message: Renoise and other plugins are not affected, but Renoise can no longer access it and thus also not save it’s actual state with the song.
Error Message: It’s most likely that this is a bug in the plugin, so please report this problem to the authors of this plugin in order to get the problem fixed.

Error Message: Ouch. The plugin ‘LennarDigital: Sylenth1’ in instrument 09 crashed, or is no longer responding.
Error Message: Renoise and other plugins are not affected, but Renoise can no longer access it and thus also not save it’s actual state with the song.
Error Message: It’s most likely that this is a bug in the plugin, so please report this problem to the authors of this plugin in order to get the problem fixed.

Error Message: Ouch. The plugin ‘LennarDigital: Sylenth1’ in instrument 0A crashed, or is no longer responding.
Error Message: Renoise and other plugins are not affected, but Renoise can no longer access it and thus also not save it’s actual state with the song.
Error Message: It’s most likely that this is a bug in the plugin, so please report this problem to the authors of this plugin in order to get the problem fixed.

Error Message: Ouch. The plugin ‘LennarDigital: Sylenth1’ in instrument 0B crashed, or is no longer responding.
Error Message: Renoise and other plugins are not affected, but Renoise can no longer access it and thus also not save it’s actual state with the song.
Error Message: It’s most likely that this is a bug in the plugin, so please report this problem to the authors of this plugin in order to get the problem fixed.

Error Message: Ouch. The plugin ‘LennarDigital: Sylenth1’ in instrument 0D crashed, or is no longer responding.
Error Message: Renoise and other plugins are not affected, but Renoise can no longer access it and thus also not save it’s actual state with the song.
Error Message: It’s most likely that this is a bug in the plugin, so please report this problem to the authors of this plugin in order to get the problem fixed.

Error Message: Ouch. The plugin ‘LennarDigital: Sylenth1’ in instrument 0E crashed, or is no longer responding.
Error Message: Renoise and other plugins are not affected, but Renoise can no longer access it and thus also not save it’s actual state with the song.
Error Message: It’s most likely that this is a bug in the plugin, so please report this problem to the authors of this plugin in order to get the problem fixed.

RenderToDisk: Leaving the render thread…
RenderToDisk: Finalize rendering…
RenderToDisk: Closing all audio files…
RenderToDisk: Restoring the song…
RenderToDisk: Starting Audio IO…

ASIO: Initializing
ASIO: Trying to open ‘Solid State Logic ASIO Driver’
ASIO: LoadAsioDriver … OK
ASIO: ASIOInit … OK
ASIO: Using SampleRate 44100
ASIO: PostOutput is not supported
ASIO: FillDriverInfo … OK
ASIO: Got kAsioSupportsTimeInfo (yes)
ASIO: Got kAsioSelectorSupported (value:2, yes)
ASIO: Got kAsioEngineVersion (2)
ASIO: Got kAsioSelectorSupported (value:3, yes)
ASIO: Got kAsioSelectorSupported (value:4, no)
ASIO: Got kAsioSelectorSupported (value:5, yes)
ASIO: Got kAsioSelectorSupported (value:6, yes)
ASIO: InputBuffers: 2 available, 2 selected - Type ASIOSTInt32LSB
ASIO: OutputBuffers: 4 available, 2 selected - Type ASIOSTInt32LSB
ASIO: OutputLatency: 2139, InputLatency: 2246
ASIO: CreateBuffers … OK
ASIO: ASIOStart … OK
ASIO: Up and running

RenderToDisk: Rendering finished…

Application: Exit…

Maybe the ((very high)) latency setting is the problem.
If you reduce the latency setting to something normal (250 ms) instead of (2139 and 2246), does the crash still occur?

Yes i tried small buffer, big buffer… same result!
Edit: 2139 and 2246 are sample size of the buffer not ms on the SSL interface, 2246 samples is around 50ms

Is there a x86 version of this synth?Have you tried it?

i did not installed the x86 but anyway, i just ordered a new ssd on amazon so tomorrow i will instal windows 10 and thats all, it will probably fix the issue! thanks guys <3

1 Like

you are on Mac os?Mac os can’t execute x86 code?

i am on win7 but it starts to be very limited for many softwares, its time to change!

Yes

Windows 7 is SLOW

1 Like

What if the “Spy disabler” software is the actual spy? :stuck_out_tongue_winking_eye:

It’s the risk…in effect

I just follow my instinct😜