Synchronizing 2 Renoises


I’ve been using trackers for 10+ years. I have a renoise licence and I love it… wonderful program.

When I play live I use two laptops running renoise and I will segue from one track to the next on either machine…

Is there a way I can synchronize these 2 instances of Renoise on these two machine, so I don’t have to babysit the beat matching?

I have never used MIDI before, but it sounds like that’s what will make this work.

Is anyone doing this? What do I need to buy to get this going?

Help! :slight_smile:

i’ve been doing that with some mates too. lovely thing, ain’t nothing better than a straight livejam. and yeah, having to beat-sync once every few minutes plainly sucks…

do you have a soundcard with midi-out on one of your laptops?

if so what you need is a simple usb-midi device (e.g. one midi in, one midi out, connected via usb) for your second 'puter. wire the midi out of laptop 1 to the midi in of laptop 2, set laptop 1 master and laptop 2 slave (in the midi-options), Bingo!

btw if you don’t have a soundcard with midi out get yourself two of these usb-midi things, they are not that expensive (about 50€). maybe there’s a cheaper way to do it but this is what should work.

you got me??

I actually got this going late last night, using emulated MIDI through my LAN connection ;) I am using a program called MIDIoverLAN.

It works great, but I noticed last night (this happened twice) that after several minutes of syncing, the slave Renoise would skip BPM and adjust to double the BPM… still syncing, but not with the desired effect, heh…

In other words, master Renoise set at 128bpm, sync begins with slave Renoise at 128bpm… then after several minutes, all of the sudden slave Renoise jumps to 256bpm.

Ever run into this problem?

err nope. sounds like a bug to me.

is this happening allways when you do a specific thing or more like coincidently?

both computers run the same version of renoise?

after all you could easily impress an audience with this thing, this breakcore stuff is still going pretty well doesn’t it.

I think I fixed it. I am pretty sure it was happening when Master was attempting to autosave.

I’ve got a show tomorrow night with this setup - so I’ll let you know how it goes :)