TC Powercore - Sidechainer doesn't work


I’ve recentely installed a TC Powercore to run the plugins that come with that card. I was happily suprised when I found a TC Sidechainer plugin in the library. You can put the Sidechainer on, lets say, the kick channel and put a TC compressor on a bassline channel. The Sidechainer should send the signal to the compressor, and duck the signal on the bassline track.

Sidechainer opens without problems and Compressor opens without any problems, but … sadly, I can’t switch on sidechaining on the compressor, because he can’t find a sidechainer “No sidechain available”.

Does anyone has experience with this plugin?

Can anybody guess what’s going wrong?

Steps to reproduce;

01 Program kick on track 01

02 Add TC Sidechainer to track 01

03 Program basseline on track 02

04 Add PowerCore CL (compressor limiter) on track 02

Expected behaviour:

01 Sidechain is button available on PowerCore CL.

02 Swtich on sidechain on PowerCore CL.

03 Sidechain signal is sent from Sidehainer on track01 to PowerCore CL on track02.

Actual behaviour:

01 Sidechain button is greyed out on PowerCore CL.

02 PowerCore CL says "“No sidechain available”


W10 64bit

Renoise 3.1.0 64bit

TC Powercore 4.4.3 64it

Sidechainer, my guess it’s running in 32bit on a dsp on the Powercore.

I tried to test it in Ableton, but the plugins are not available there, I think this is because they are 32bit.

The TC plugins are installed like any other, 32bit, plugins, but they are loaded in the TC card (I think). You need the card to run these plugins.

Man, as I wrote :

if those plug-ins are 32bit, first try renoise 32bit, and make sure sandboxing is disabled in the renoise preferences. Because else sandboxing / bridging is enabled, which causes each single plug-in to run in a separate process - so if this sidechain really is based on a custom communication between those plug-in instances, of course a non usual running in different processes will commonly prevent such mechanism.

I run the plugins in sandboxes and use 64bit Renoise, so there is enough to test, thanks!

Lol… Don’t you get what I wrote? Don’t expect anyone to test this, because nobody has this processing card anymore.

Lol… Don’t you get what I wrote? Don’t expect anyone to test this, because nobody has this processing card anymore.

Offcourse I don’t expect anybody else to test this, what kind of person do you think I am :slight_smile: I’m just glad I have got some directions with possible solutions to check out myself when I’m back home tonight.

Sorry totally misunderstood then :slight_smile:

Could installing jbridge be a solution?

I don’t think so, but try it.

Well, the sidechainer works in Renoise 32bit.