Touch Osc, How To Configure ?

Maybe I’ve missed some doc or thread (yes I did a search :) ) but how do you configure to use an IPAD with Touch OSC to control Renoise ?
I’ve tried duplex but don’t seem to be able to make a connection to the IPAD, have tried different ports, turned off firewalls etc. but no luck.
Is it necessary to use e.g. PD if you use Duplex ?
As far as I know PD is if you want to convert the OSC commands to MidiCC but again please correct me if I’m wrong.

By the way, what is Prefix in the Device Settings in the Touch OSC duplex settings box ?
Is Prefix the same as subnet or is it some OSC specific setting ?

If you’re sure both devices are on the same local network, they should have a similar IP address:
In my own setup, the iThing is and my workstation is, so I enter into the Duplex setting dialog.
You can safely ignore the prefix, this is mostly for when using multiple devices or devices that require a prefix.

The port names need to be the same on both iThing and your workstation - e.g. “8001 out” on the iThing, “8001 in” on the workstation, etc. Simply try with the basic TouchOSC preset. It should work with the iPad as well, although it’s based of the iPhone template. Both templates share similar names (like “/1/fader1”), so you should be able to see when/if something is responding.

PS: there’s no need for external software, Duplex should work out of the box.

Yep, I can ping the ipad, and I’ve entered the ipad’s IP in the Duplex settings.
The input port in duplex is the one that set as output on the ipad anv vice versa.
I’ve tried switching the ports around just to make sure :)
But the ipad doesn’t get the host to pop up when configuring the ipad.

By the way, is it bug that when manually entering the port numbers in the settings dialog window ?
I they are above 1024 they will changed to 1024, if I uninstall duplex and re-add it it will default to 8081 and 8001.
If I change those e.g. switch them around they will become 1024 instead of what I type :)

Can you ping your computer from the iPad as well? If so, perhaps you can make a simple PD document that print any incoming OSC messages, to see if anything comes across (if not, I can help you make one)?

That sounds strange. Anything below 1024 is reserved, because you can’t use those ports on linux systems. But you’re saying that a value above 1024 will cause this?
Re-installing Duplex should trash the preferences and revert to the default values (8080, 8001)

Got it to work now, after some more reading, so it was a bit of PEBCAK :)

But yes, as soon as I enter e.g. 8500 as port number it reverts to 1024 :)
Have uninstalled/reinstalled Duplex multiple times now.