Track DSP Commands clicking noise

Tried this for the first time:
‘1000’ to switch off an effect, ‘1001’ to switch on.
It’s on one track playing a rimshot and a Multitap Delay.
For the first hit I switch it off, the second on.
If I place the ‘1000’ in one row with the rimshot hit it clicks very loud.
If I place it 3 lines above it’s still there, but not so loud.

How can I avoid this?

Edit again = I’m just not sure if I got that right for you. Because, you are talking about a, “clicking noise.” If the clicking is from the effect, and not from a spike in the rim-shots volume, than I do not believe my answer is correct. I am sure there is a solution, but it may just be, “giving yourself a buffer line.”

Just fyi, to help you see something: Notice those effect command numbers correspond to the postion of a certain effect on your chain. Effects 10, 20, 30, 40, etc.

Now about your question. “This may not be the answer you want, but I am pretty sure, this is the answer.”

When mixing music, or recording music, or playing with sounds inside our daws. We may have certain sounds that, “peak or jump out at us.” Those types of peaks, and volume spikes, are traditionally handled through Dynamic Range Compression.

Thus, there are several options to tame this sort of behavior.

First: We must be sure that this behavior, is indeed related to volume. ( I believe it is. ) It could also be related to an audio glitch, “it is a click,” but lets not get too complicated.

Second: We can limit the signal with a look ahead brick wall, or we can tame the signal with some compressor settings.

I would try taking the Renoise compressor from your native dsp fx, and dropping it on the track after the delay. Try a very short attack, a longer release than attack, and because its a rim shot, I’d go for a ratio of 4:1… bring the threashold slider down until you reckon you are getting about 4db of gain reduction.

Let us know what you think, hopefully what I have said is correct. I guess their is always the chance, that you know this technique, and I am wrong… If that is the case, my apologies.

Cheers

Edit = I like these comp settings here https://www.box.com/s/y4l9zvkoavgimcts5r77

I never use makeup gain, unless I need to use it… lol… that doesn’t make sense, “oh well.”

Thanks 2 daze j.
No, it’s not from the sample, it is really a switching noise.
Curiosly it’s gone when I solo the track.

I’ll try what you suggest.
But as far my recording experience tells me: Before I begin to adjust anything using fx tools it is better to have a clean source…

If it helps I’ll attach a screenshot for better illustration. It depends just on switching the delay on and off - it is only the delay in the chain, so 10… is right, isn’t it?

If you only have a delay in the chain that’s ten. I just tried this… I’m hearing the delay turn on and off, “very smoothly,” unless you can hear something I am missing? That would be slightly embarrasing on my part.

There is a click in the background, but that click is just a low volume echo from the delay… Notice the comp blinking on/off… that’s fx #20… ( it took me a while to figure that out, that’s all I’m saying. so I thought I’d share it. )

https://www.box.com/s/ww2utsql8k9cz6vuqrad

But to sum up: You might have to switch your sample? Do you think Example B is smooth? If so, you might need a different rim shot

I don’t hear any noises similar to what I’m speaking of in your example.

Here is my .xrns.

In the first pattern in track03 I set the ‘1000’ to a position where the click noise is acceptable. In the second pattern it is placed different and I can clearly hear the noise.
If I switch track03 to ‘solo’ the noise is gone.
Can you hear it?

Basically, I think that the click is on the sample. The samples in your 808 kit seem, “extremely trimmed.” I don’t know if that is to save memory, or hd space, or because somebody likes there samples neat and trim.

I think you have a classic, “zero crossing click,” or a click that would happen from the audio wav not being cut at its zero crossing.

When you solo the track, “delay hides it,” and when all three tracks are on, “the click stands out,” and when you solo the track, and turn off the delay completely you can hear the click on the sample itself.

Here is an 808 Rimshot, cut and sampled by Roland Music Corp:

The sample below is from the 808 in your xrns, and I have put a bracket around where I think the click may be. It could also be at the end of the wav form. Its a little difficult to tell, “odds are, the click is at the transient.”

Just to compare a little more, “this rim shot below,” is from a very famous rock/metal producer.

The sample has room to breathe. Without it, “you will run into problems.”

:slight_smile:

I hope this helps. ( ofcourse, when you are chopping up a break, or a loop, the sample wont have, “breathing room,” so you must be very careful to chop proper, or you get a click ) but with str8 up drum samples, “extra space,” isn’t really a bad thing.

Cheers

Unfortunately no, it doesn’t help. Tried with other samples and it’s still the same.

Turning FX on and off can cause clicks, if the difference between the original signal and the effected one is large enough.
For example, a ringmod will most certainly cause a noticeable click, while distortion is so harsh to begin with that you hardly notice it.

Also, some devices introduce a delay for their internal processing. If PDC (plugin delay compensation) is enabled, the whole song
might be pushed a few samples back and forward in time, which could lead to artifacts as well.

So, best bet would be to route your effected signal to a send track and then crossfade between the effected and the original.
This will be less likely to produce clicks, as the gainers movements receive a small amount of interpolation, and the device(s)
that introduce delay are present at all times.

Such a crossfade could be establishing using 3 devices:

Hydra -> Send (keep source) -> Gainer

Then you make the hydra control the Send gain and the Gainer, but with opposite values - this will turn it into a crossfading device.
And obviously, you would then have to use the effect command to control the hydra instead of the DSP on/off switch…

I don’t this is the case here, but anyway we have an option in the instrument sample settings (auto-fade) that is supposed to eliminate clicks as a result from zero crossing samples.

I hear you on that… I guess give danoise’s solution a shot… I looked at your project again… I’m wondering if that click is from the bp filter on the multi-tap. When I tried auto-fade, and switched the bp to an hp or lp, things really seemed to smooth out.

https://www.box.com/s/b2nrf5v79hiz8qytzkun

Also, “I guess there is no denying, that we all have different audio cards and stuff.” What clicks on one system, may not click on another, and that can be a huge problem, when trying to get any sort of perfect response, to situations like this.

Cheers

Thank you both, Danoise and 2 daze j!

Before I read your idea, Danoise, I made a small track with different samples and the noise appears again.
First I tried without any samples, just switching the delay using ‘1000’ und ‘1001’.
Then I added the rimshot on Track02 - still silence.
After I added the kick on Track01 the switching noise is listenable again.

Here it is

I’ll try your suggestions. Of course there might be different solutions or tricks to avoid this behaviour (if it helps at least…), but to me it feels a bit annoying to set up a complex routing just to get a fx switched on and off.

Hi scaai,

hmm… We have a conundrum.

What is your brand audio card, and audio device settings? Edit —> Preferences —> Audio ( The driver, and the latency ) Because I hear no, “extra click.” Just echo off the delay, and the low velocity kick… I am hearing, “digital clipping,” from the maximizer…

Is that a multi-tap dubstep preset? If you change the bp filter, to something like an LP, the echo has more frequency, and the report of the echo has more of the original fatness from the rim shot.

Edit = I was thinking about it… I know danoise’s suggestion is a bit complex, but it might just be the only way. A lot of times mixing does get, “extremely complex,” and I can totally hear clicks and stuff in my fx.

The next time I run into one, I going to give this hydra routing setup a shot!! :slight_smile:

2 daze j, it’s an EMU 1616m PCMCIA set to 44.1kHz and 5.1ms latency (224 samples).
I sat up this latency for Reaper also (I play bass guitar btw) and it worked fine - as long as I don’t forget to deactivate the WIFI-adapter before. Latency Mon showed to me that this driver takes a lot.
Working with renoise I didn’t switch the WIFI, yet. Should give it a try…
What do you think?

Yes, it’s just the Dub Simple Preset.

I tried Danoise’s setup - works, but really complex.
Then I went from switching the Multitap DSP on and off (‘1001’, ‘1000’) to control the fx amount using ‘16A0’ and ‘1600’.
Because the delay feedback was so long (50%)and overlapped with the sample that shouldn’t sound delayed I set an ‘1100’ command a few lines below the ‘1600’, too. This switches the panic button of the delay and all feedback off immediately.
And with this command the noise appeared again even louder.
Now I sat the feedback of the delay to 25% and just switched the delay amount betwenn -INF dB and -4 dB and it works.

Turning off the wifi? Could help…

You might just have to go with danoise’s suggestion

but you might try… a different delay, and perhaps a freeware? Sometimes, with some projects, you can just, “switch the plug, and kill the problem.” That’s the funny thing with these computer softwares…

There’s one inside of Reaplugs, http://www.reaper.fm/reaplugs/index.php

or a good looking freeware like this: http://www.voxengo.com/product/tempodelay/

there’s a sick multitap from expert sleepers… I guess I used to use it when I had a mac, cause I can not find a vst :frowning: which is such a shame!!! I used this guys plugs non-stop. He has a great verb too http://www.expert-sleepers.co.uk/multitap.html

Aside from that… Anti-virus is notorious for screwing up the audio-card mojo… I’m using microsoft sec essentials, in tandem with spybot and malwarebytes… but I’ve tried norton and mcaffee, and avg, and I’ve had nightmares getting good solid audio with them running.

But… try a different delay, cause maybe your system will like it more. I love Renoise’ multi-tap too. I think its a great delay, do not get me wrong. but maybe for this one project, you are having some weird glitch