Transport starts as soon as I enter edit mode, records the same note until I escape

New Renoise user - I downloaded it earlier this evening, following the tutorial about making a beat, so one sample loaded in 00, then to first track, hit escape to enable edit mode. The transport starts running and it places the same note over and over until I escape out again.

Is this a macOS Catalina issue with Renoise? I’ve tried to figure out if a setting is wrong, but I haven’t changed anything from the way it comes when you open up for the first time.

have you tried enabling ‘following option’?
if not - ren001 i seem not to understand your issue at all

Yes, that’s enabled.

What I mean is that it’s auto-recording as soon as I hit escape or the record button to enable editing. Before I can enter a note, it runs through the entire column entering the same note over and over.

This is what happens after enabling record - I thought maybe it was a stuck key somehow, but the behavior repeats itself on another keyboard, wired or via Bluetooth.

Can you try that in a text editor? Check if characters are entered in a text editor without pressing any key.

Renoise does nothing strange here. Something must happen for a specific note (E-3) to be continuously recorded.

The real action would be to keep a specific key on your alphanumeric keyboard always pressed. Either you have a bad physical keyboard, or even the cause is a of a virus. You have to rule out possibilities.

1 Like

There are no issues in text editors or in other DAWs (or in a FastTracker II emulation). The issue happens with a second keyboard as well - and I just checked, it happens with no keyboard attached at all.

I ran a malware check just in case but nothing there either.

Do you have any MIDI keyboard connected?

Clean Renoise install, no extra tools?

No MIDI devices connected, and the Mac demo doesn’t really have an installer - it’s just a built application that launches.

Sounds dumb, but can you power off that bluetooth/wireless keyboard and check if there is really no other input device connected to your MAC?! If this would be a bug with Catalina, i guess someone else has this too.

1 Like

Yep, it happens with the keyboard off and on, and also with my Magic Trackpad off and on. Definitely nothing else connected.

Neither Ableton nor Logic can find Redux (demo) as a AU or VST so I can’t test it there… but I’m guessing that means it’s a compatibility issue in general.