Trouble with ReWire between Logic Pro X and Renoise

For the past couple days I’ve been doing my best to trouble shoot this by digging through old threads here relating to rewire. I’ve tried multiple different applications with Renoise trying to accomplish any rewire connection at all. It seems like Renoise is having trouble detecting other programs.

I’m using an M1 mac laptop with the most recent OS. My goal is to have Renoise function as a ReWire slave and route audio into Logic. I’ve gone through my security settings and given every permission to Renoise that it was requesting, and the same with Logic. I’ve tried both ReWire modes in Logic, and I’ve uninstalled and reinstalled both applications. Both are running their most recent versions.

I feel like I’m missing something. I’m launching Logic first and creating a song, and then I launch Renoise and the usual ReWire slave popup isn’t showing up. Do I need to download something else for ReWire to function? Is there a settings area in Renoise I’m missing where ReWire could be disabled? Is anyone else experiencing an issue like this with M1 Macs?

Any help is appreciated.

Rewire unfortunately is not available for ARM based Mac Applications, as it has been depreciated by Propellerhead a long time ago.

Man … what are we gonna do without ReWire … Link just isnt cutting it. We need ReNoiseWire!

I see. Thanks. I wish that the newer mac versions had jack support, then. Either way I’m glad to know I’m not just being an idiot.

1 Like