Ubuntu Problems

Hello, I’m new to both Renoise and Ubuntu, recently took the plunge to use ubuntu as the stability and design of the OS appealed to me. My question is probably going to come across as very noob-ish, however, it needs to be resolved non the less. I have been a user of Cubase for years but wanted to try something new so have downloaded the renoise Demo (with intent of buying).The problem is, when I run the install.sh file in the terminal, the terminal simply closes and nothing happens. Following this I attempted to run the install within the terminal, which looked like this:

paddy@paddy-HP-Pavilion-dv6-Notebook-PC:~$ cd
paddy@paddy-HP-Pavilion-dv6-Notebook-PC:~$ cd Renoise_2_6_0_Demo_x86_64
paddy@paddy-HP-Pavilion-dv6-Notebook-PC:~/Renoise_2_6_0_Demo_x86_64$ sh install.sh
Sorry, must be root to (un)install…

I then, attempted to run this:
paddy@paddy-HP-Pavilion-dv6-Notebook-PC:~/Renoise_2_6_0_Demo_x86_64$ ./renoise
bash: ./renoise: Permission denied

For some reason I am told that Permission is denied, despite the fact permissions for all of the relevant files are granted.

Any help? Please, be easy on me and bare in mind I am a complete noob to this OS.

Thank you.

Thank you!

Can’t believe it was that easy!

Sorry, install has worked, however when I try and run it, it will not open. Any suggestions on what may have gone wrong?

Sorry, another noob question, but how do I run as Sudo, presumably I should be typing something along the lines of

paddy@paddy-HP-Pavilion-dv6-Notebook-PC:~/Renoise_2_6_0_Demo_x86_64$ gksudo application.renoise

However, this has the same effect as attempting to run from desktop icon?

Have also tried this:

paddy@paddy-HP-Pavilion-dv6-Notebook-PC:~$ gksudo application.name
paddy@paddy-HP-Pavilion-dv6-Notebook-PC:~$ renoise
bash: /usr/local/bin/renoise: cannot execute binary file

which did not work.

Thank you.

Thank you for the response and for being patient, I’m sure it must get annoying having noobs ask questions such as these.

Did you manage to install it? If not, you could try this:

go to the directory where you managed to unpackage the download and try these commands:

 cd ~/Renoise_2_6_0_Demo_x86_64  
 chmod +x ./install.sh  
 sudo ./install.sh  

Hopefully this will work and will put an icon in your “Sound” menu, which should run Renoise for you as the currently logged in user (ie “paddy”).

Hey, thanks for response, install worked fine, the problem is that now the program has installed and shows up under “sound”, when I click the icon to execute nothing happens, have tried uninstall then reinstall and the same happens! I’m a bit baffled really.

Try ```
sudo chmod +x /usr/local/bin/renoise


thanks for the response. Have tried this to no avail. really scratching my head now. if it helps I’m having the same problem with the programs MuSE and Freebirth that I downloaded from the software centre.


Probably a stupid question, but since you are installing the 64 bit version of Renoise: You do have a 64 bit machine, right?


hey, yeah it’s running on an AMD 64bit processor - although I may try running the 32bit version to see if it makes any difference.

Hey Guys, thanks for your help, turns out I made a really rookie mistake in the terminal - after installing renoise successfully I didn’t type the command ```


I think you didn’t get the point :)

If you want to run renoise in this way - you don’t need installation.