Ubuntu (Unity): Strange Cpu Load Issues


I’m not sure if this is related to the way things are setup in my system or is it Renoise’s fault but when Audio device is set to ALSA the CPU is oscilating between 4-8% just after Renoise is started and it goes up to 100% when I move the window. When it is set to JACK the CPU load is lower (between 0.7-1.5%) but when I move some windows, for example Firefox, it goes up to 22% (where it stops). It is quite strange on a i7 desktop CPU with 6 gb RAM…

It may be the Unity as it is quite heavy and it is still a work in progress as I suppose. I notice better audio performance with more lightweight DMs but it is still strange for Renoise to be that sensitive. Even apps run in WINE (like Reaktor 5) aren’t affected by this.

My system is Ubuntu 12.04 with some KXStudio packeges, namely jack2 with bridges to pulse audio, alsa2jack midi etc. I have generic kernel. Some apps behave strange when JACK is running and they are set to ALSA but none had problems when were set to JACK or PulseAudio. My graphics card is Radeon HD 4670 with ATI’s drivers installed.

Try sudo apt-get install indicator-cpufreq. This installs an cpu applet after a reboot. Set it to performance. Try updating the amd driver from amd website, version 12.8

Perhaps the gnome session fallback will help too. Then you have the classic gnome look and not unity

Thanks for the advice.

I do have the cpu-indicator installed and it is set to performance. Dropping Unity is not a solution… it’s like advising going to MacOS when something is wrong with Windows.

I’m still at the “getting it to work” stage so things change pretty quickly. A few days ago I installed xfce and it messed some things up. After removal, for reason unknown to me, it changed default session from unity to unity 2d. After setting it back to unity things work better. I have also changed the kernel to lowlatency. Now the CPU usage is far more stable but there is still huge difference between JACK and ALSA. With JACK it is exactly 0.7% but when I change it to ALSA it is 5% and it rises to 7% when I grab the window and touch the screen’s border with it. I don’t understand why this is happening but I don’t think it is normal behaviour.

Why not? It’s known to be problematic and you will almost no serious audio users will to use it for this reason! Try searching the LUA list or similar.

No it’s not. It’s more like recommending using Notepad++ when you find OpenOffice to be bloatware, using too much system resources for an underpowered computer. Perfectly fair suggestion!

XFCE would be my personal recommendation. Reportedly the Classic Gnome in Gnome3, although it doesn’t use Unity still is a serious resource hog and nowhere near approaches the performance of Gnome2.

Definitely not. This only regards the user interface here, not the kernel underneath it.

If you want to do serious audio production with Renoise in Linux, you have to let go of the idea this can be done in any fancy window manager.
Linux and its bloat-expanding layers of audio drivers is already a problem of itself in general, you have the opportunity to keep the UI simple so best advise is to try keeping at least control of that.

[s]You have a point in advising the move from heavier DM to lighter one. Although, what I meant was not the technical aspect but the preference. I like Unity very much, it’s one of the reasons I’m still going back to Ubuntu despite I have failed to configure a working DAW numerous times. Yesterday I managed to configure WINE and get some apps (NI stuff) I need to work almost flawlessly for the first time. This is a milestone to me. I believe Unity will improve, in fact the development version has a lot of fixes along with metacity removal etc (I’m going to try the unstable version and see if it improved). There are people who run DAWs in KDE and it is working fine, so why not? Especially that my pc is quite up to the task. I will try…

On the sidenote, I dislike XFCE and LXDE, they are limited (especially lxde) and remind me of windows 98… just an opinion though.[/s]

Screw this, it’s not going to work anyway. Sorry for wasting your time, pals.