UI freeze when accessing samples/instruments

I have a pretty decent setup (i7, 8gig ram, 1to samsung ssd on W10) but I experience often an UI freeze (that doesn’t affect sound rendering if it’s running but can get to 5 seconds in the worst case) when I read samples on the disk before loading them, or go inside an instrument to manipulate samples already loaded/recorded… After the first freeze it doesn’t occur for some time, like if it was a cache story…

That’s not really a problem and I can handle it without pain but I was wondering what could cause this and if someone else experience this ? I already tried to wipe my Renoise profile and start with a new configuration (but with the same vsts) and I get the same behavior… Could that be that I have too much VSTs ? (maybe something like 50… not that much imho, but maybe ?)

What would you look into ?

nb: I didn’t already installed rns 3.3, could it fix this ? I didn’t see much thing about this in changelog but maybe I read too fast…

Have the ‘Power Plan’ settings been checked? Sometimes…
if ‘Turn off hard disks (after x minutes of inactivity)’ is enabled;
symptoms like this can occur.

I have performance plan enforced, but maybe hard drive has a specific parameter, I gotta double check this…

Were you able to find a solution? I am having the same issue, even on tracks without any VSTs. It’ll usually happen with a particular sample within the track each time I initially load the track, but it’s only during the first play throug. Loading the track and rendering doesn’t produce the lag.

Is the disk op / disk browser open when this happens? Is there a difference if the diskbrowser is collapsed or not?

seems like my issue… No, still the same here… I’m wondering if it’s not linked to some vst. I’ll test that when I have a moment.

Do you have tools installed, does it matter/differ if you disable the tools in the tool browser? Access here;
image

I have 2 small tools about recording midi, I already tried to uninstall them with no success… BUT I have a strong lead :slight_smile:
When I disable VSTs, no more freeze… I don’t have a clue why but I think there’s a bad VST fu*king with renoise plugin list or something nasty…
I think I might empty my vst folders and add vst one after another in order to find the black sheep :slight_smile: