Unable to assign one MIDI channel only to one instrument only


(Marco) #1

Hi there,

I’ve been using Renoise for many years (and love it!), but I generally don’t work with MIDI. Hence my questions here.

I’m on Linux Mint 19 with Renoise 3.1.

I’m using PureData to generate MIDI notes on two MIDI Channels (Ch1 and Ch2).

I want to assign each MIDI Input Channel to one instrument, so I use the Input Device tab in the MIDI section to do so.

Instrument 1 = MIDI Input Ch. 1
Instrument 2 = MIDI Input Ch. 2

AFAIK, this should result in MIDI notes on Channel 1 to activate Instrument 1 only, and notes on Channel 2 to activate Instrument 2 only. However, that’s not the case and I can’t understand why.

What actually happens is that any note on any channel activate whatever instrument is selected in the Instrument Tab. This also means that if I select another Instrument as the notes are coming in, the newly selected instrument will start playing and the old one will stop.

I doubled checked that the routing is correct using both “Show Routing Overview” and the plugin “MIDI Management Console”.

In the screenshot attached, as a test, I’m generating notes on MIDI Channel 4 to see if Instrument 1 gets activated. And indeed that’s what happens. Despite Instrument 1 being assigned to MIDI Input Channel 1, it still gets activated by notes on Channel 4, as you can see from the scope at the top.
Screenshot%20from%202019-05-29%2016-39-54

any hint?

many thanks in advance, and excuse if I’m missing something obvious.
I’ve researched online and in the forum to no avail.

cheers,
M


(Baticus Arelius) #2

Good lord I’m dealing with this too. It’s drivin me crazy! It’s like midi inputs just go where they want. I noticed the cursor position is important in writing the notes in the right track column, but why??? If I select the kick for example, it should just record kick notes in the kick track column. I group the drum kit together, and the basses together, and the leads etc on their own tracks so but swapping from instrument to instrument records on the same column. I managed to stop this behavior earlier by switching to channel B but it stopped working again so that’s why I’m here too. Love the concept of a tracker. I can already tell I’m going to produce my best work yet with Renoise. Just gotta work out these frekin bugs. Let me know if you figure out the problem as I’ll do the same.


(Raul (ulneiz)) #3

I have tried this with a MIDI controller keyboard and it works correctly under Windows 10. It is only necessary to make sure that each instrument is correctly routed:

  1. Selection of the input device
  2. MIDI channel selection.
  3. Selection of the destination track.

These three steps for each instrument (you can also assign a range of notes).

Note: The version of Windows 10 is not the same as for Linux. It is possible that there are problems in one version and in the other they do not exist and vice versa.

There should be a user who tries it with Linux

What MIDI device controller are you using?


(Baticus Arelius) #4

I’m using a launchpad (w/duplex tool) and I’m also using an Akai Key25. I’m also Using Renoise 3.1 on a Mac.


(U4iC) #5

Do you both have the midi device set as your master keyboard in Midi Preferences, as well as routed to specific tracks? Master keyboard will play where your cursor is at.


(Marco) #6

Master keyboard will play where your cursor is at.

U4iC that was it.
Leaving MIDI Master Device empty, and assigning MIDI devices/channels to individual instruments fixes the issue.

It does make sense too. Is this documented in renoise docs?
I can’t find it, although perhaps it’s common knowledge that I just missed?

Thank you U4iC, Raul and Baticus.

@Baticus, hopefully this fixes it for you too?