Unable to use Rubberband or time stretch a sample

Hi There,

I am new to Renoise, but not to music on computers…

I am having a tricky time with stretching a sample. Rubberband, though installed is not working. So I follow the directions and go to Homebrew, but my MAC terminal app won’t allow the script to run. Additionally, when I try to time stretch from the other option available, I get an error message talking about issues with installation or that what I am trying to do is too much for my system (which is not the case)…

Any ideas as to what is going on/ what I can do?

Thanks so much


"When enabled, the sample’s length will be automatically changed so that it lasts for the stated amount of pattern lines and is especially useful for syncing drumbeat loops. It will also automatically update its length if the song changes BPM or LPB. As an alternative, you can leave the tickbox disabled and instead press the 3.0 sampler-beatsyncT.png button, which will automatically set the Transpose and Finetuning values to match the current BPM and LPB.

  • Mode: When Beatsync is enabled, you can choose how this affects the sample playback from the following three methods:
    • Repitch: The sample is ‘locked’ at the pitch that matches the song’s tempo and you will be unable to use it at other pitches. This also disables the Transpose and Finetune parameters.
    • Time-Stretch (Percussion): The sample can be played at any pitch via time-stretching, with a priority for preserving fast attacks, making it ideal for percussion.
    • Time-Stretch (Texture): The sample can be played at any pitch via time-stretching, with a priority for preserving tonal accuracy, making it ideal for textures."

Hi There,

Thanks for the help…I understood that portion of the sampler, but was having trouble with Rubberband specifically . After some more “problem solving” I realized I have come up against my limit of computer know how…I have downloaded and run Homebrew, but when I try to run the script in from the Rubberband Config window, the command does not exist. Also the default path specified does not exist on my machine. I will reach out to the developers for help, as this is a little too perplexing for me. Renoise is the perfect compliment however to my other software - extremely enjoyable and rewarding

Probably you already know of this, but there are some Rubberband Tools for Renoise:


Reading your first post, I am assuming you’re discussing Rubberband from an ‘outside of Renoise’ point of view. I do not understand. I know Homebrew through Terminal is one way to install extra code libraries - I fiddle around with it from time to time on my Mac, mostly for TTS purposes.

As an aside, I’m hoping that one day, the time-stretch function that is in Renoise becomes like the one called ‘elastique’ in Reaper or straight up ‘paulstretch’. Rubberband always sounds sort of grainy whenever I use it. I prefer the smoothness of paulstretch or elastique. Smoother and more articulate than Rubberband in either ‘percussive’ or ‘texture’ mode.

I did find and download those, but I must have an incorrect file path somewhere…when I’ve tried to use Rubberband, I get an error window popup and it mentioned running Homebrew, so I tried it…I really did not have a clue what I was doing , but gave it a go nonetheless. I came to making music on computers from being an acoustic musician, so my skill set of computers is quite limited…I have other ways of stretching the audio and loops ( outside of Renoise and/or using a VST ) but thought it would be faster to use a Renoise Tool.