Usb Devices Troubles In Linux

I am trying out the renoise demo on my recently built computer running Ubuntu Studio 10.10 but when I start renoise, I continually get error messages about renoise not being able to create realtime threads, etc. I searched the Linux FAQ and found this:

"To allow Renoise to create realtime threads, which are required for low latencies with ALSA or JACK, you have to edit the /etc/security/limits.conf file. A realtime kernel does NOT help here, does not set the required options automatically! To enable RT thread creation via PAM open the /etc/security/limits.conf file as root (or via sudo). Then somewhere at the end of the file add:

YOURUSERNAME - rtprio 99
Alternatively you could also create a group “Audio”, add your user to that group, and use “@Audio” instead of “YOURUSERNAME”.Save. Log Out. Login. Then it should work. To make sure that it works, launch Renoise, select ALSA and make sure the “Realtime threads” option is on. You will get a friendly warning if RT creation failed.You can find a more detailed explanation about PAM and low latencies in Linux here"

But as I am a Linux roob, I have absolutely no idea how to do this. I searched my machine for the file “limits.conf” but to no avail.

I am not sure if this is related but my M-Audio Fastrack Pro USB Audio Device is not working with the program.

Any help would be greatly appreciated!!

Forgive my verbosity if this is old news, but here’s a rudimentary explanation.

When you see something like /etc/security/limits.conf, it’s a filesystem path. In Windows, a path looks like C:\Program Files\Renoise, for example. Here, limits.conf is a plain text file.

The path /etc/security/limits.conf starts with / (a slash), which means it begins in the root directory. You don’t need to search for the file limits.conf – you can access it directly with a terminal (Ubuntu menu -> Accessories -> Terminal) and type

gksudo gedit /etc/security/limits.conf  

…then enter your password, then edit & save the file. You only need to do it this way (through a terminal with sudo or gksudo) because the file requires administrator permissions to edit.

On Ubuntu Studio, you’d want to use @audio in that file instead of your username, but I don’t think regular Ubuntu has an “audio” group, so use your username.

Thanks, I did this and it didn’t work so I just reinstalled the OS and now I am no longer receiving error messages but I am unable to hear any audio from my sound card. I have it running in ALSA and it comes up as two choices USB sound device and USB sound device #1 (or something to that effect). I have tried selecting each and neither produces any sound (nor visible level on the meter at the top).

Does anyone know whether I should be using ALSA or JACK? Is there a configuration or something somewhere I’m not getting?


So the latest development is that I go into the Jack Setup and it registers the FastTrack Pro as a usable card. I set it as the default, then go into ReNoise and it gives me the error message that the device is being used. It’s driving me nuts! The soundcard works perfectly for system sounds and YouTube but for some reason, I can’t get it to work in renoise!!


I have had trouble with my usb soundcard and my onboard card. In a forum the people told me to edit a config file:


options snd-usb-audio index=0
options snd-hda-intel index=1

This set the usb-card as the first device. This has helped me and i hope this brings you a step forward.
Sometimes if i open my qjackctl it will not working and is blocked. I close my browser and then i restart qjackctl and voila it starts.

As said hope it will help you. ^_^

Set realtime priority in

Code (type this lines in the file):

@audio - rtprio 100
@audio - nice -10