Using Shortcuts With Control Key With Ubuntu Linux


I’m not sure whether this is a bug, a feature, or an OS problem: Keyboard shortcuts containing the control key (like Ctrl-S, Ctrl-N, Ctrl-O) behave strange in Renoise on my Ubuntu Linux 12.04 installation. On my MacBook Pro they behave as I would expect them to behave. So I guess those shortcuts should work the same on Linux.

Say I want to save my work by pressing Ctrl+S then Renoise just plays the note under key S instead of saving. Though it works when I hold the control key several seconds (~3 sec.) before pressing the S key. It appears as if it takes some time until Renoise recognizes that the control key is pressed.

I tried the shortcut in other programs and it works there so it does not seem to be a hardware or a general OS problem.

Is it a known problem and what can I do about it. It’s kind of annoying for my work flow because I press Ctrl-S quite often while working on a song.


I can’t check it out, anyway:
Edit => Preferences => GUI should have an “ignore window manager shortcuts” checkbox somewhere. try if changing the state of this checkbox helps

Same behavior no matter what state the checkbox has. I also tried a different keyboard.

EDIT: The icon of Renoise in the Ubuntu/Unity task bar bounces when it recognizes the Ctrl-S command. Is there anything I can do to Ubuntu/Unity to make it work properly?

I’m running Ubuntu 12.04 LTS with Unity and the Renoise Shortcuts (CTRL+S, CTRL+N, CTRL+O) work fine.

  • What’s your keyboard layout?
  • What do you have under: Settings -> Language Support -> Keyboard Input Method System
  • Any weird bindings in your ~/.xmodmap file?

Me it’s QWERTY, and ibus.

My keyboard layout is QWERTZ. It’s an Apple keyboard but I already tried a standard PC keyboard. Same behavior.

Keyboard Input Method System was set to none. I just tried each option in the list: ibus, lo-gtk, th-gtk. Same behavior for each option.

There is no .xmodmap file in my home directory so I guess everything is set to default there.

My Ubuntu 12.04 installation is quite new and I haven’t modified much.