Vanguard 1.11 Clipping In Gat Classic Ms

I’m having problems with the preset “GAT Classic MS”. Try entering a few notes in a track and play the song, you’ll hear irritating clipping sounds - when you swtich to 96 kHz the clipping will get less annoying yet still annoying. Can somebody PLEASE try to reproduce this in another host say Cubase, Sonar or whatever!?

I have 1.11 and I tried a track of notes with the mentioned patch and I could
not hear any artifacts at all. Really clear as a whistle. But the single VSTi
was quite heavy load (!). Between 18 and 25 percent of CPU depending on
polyphony, on a 3ghz p4

Thanks a lot, Mike! :) Can you please try to reproduce this in Renoise also? Please hurry, if this is a bug within Renoise then it would be nice if the devs could fix this before the final release og Renoise 1.5. ;) I believe you feel the same way. :) Btw which host did you try this in?

I tried this in both borh cubase 3 sx and Renoise 1.5rc2 works fine. If you
render a sample is there a click in there too?

Damn :( Hmm… I’ve tried to use the “render selection to sample” function and yes, there was stil a lot og clipping going on. :( … actually, I haven’t tried in RC2 only in RC1, but I doubt there will be a difference… I’ll test it immediately ;) .

Why are you still using RC1? If there is a problem in RC2 that stops you from working with it, we should know about it.

Damn!!! :@ It’s stil there, no matter how I tweak the sound it still clips! :@

Crap! I’ll try to remake the preset using another one.

Ok, I now what’s wrong now, it’s the band 24 dB Filter that makes the preset go clickedy click. :S

Bah! :@ It’s not the only Filter that causes this problem…

I just checked the “master scopes” and it looks like this patch has a very
peculiar waveform that is very prone to get clipping. Notice the low “teeth”
on it? It is not symmetric around the “0 (silence) line”, so you have to crank
up the volume more to get loud.

When I cranked up the volume I too got the clipping.

So this also happens in Cubase, right?

BonusNinja: Have you simply tried to lower the master volume?


I played around in Renoise with the Vanguard preset you mentioned, and I was able to get it to “click” sometimes, but I usually had to be playing quite a lot of random notes/chords all at once, just pressing random keys and stuff.

Personally, I think the problem is related to Vanguard’s audio engine, or more specifically the gating effect routine. It seems to work perfectly fine if you have notes/chords which are in sync with the bpm, so the gating pattern kind of flows continuously on-beat.

For example:

00 - C-5 - G-5
01 - OFF - OFF
02 - — - —
03 - — - —
04 - C-5 - G-5
05 - OFF - OFF
06 - — - —
07 - — - —

This doesn’t seem to cause any problems when the notes are always on-beat.

00 - C-5 - G-5
01 - OFF - OFF
02 - — - —
03 - C-5 - G-5
04 - OFF - OFF
05 - C-5 - G-5
06 - OFF - OFF
07 - — - —

But something like this seems to cause the occasional clicking. My guess is because the internal gating pattern in Vanguard is being forced to reset constantly at off-beat positions, if you understand. And something to do with the gating pattern not being reset precisely on an even/on-beat position, is causing the clicking.

So… I’m not sure this is to do with Renoise. Technically I think Renoise is doing exactly what it should do, and Vanguard simply acts a bit weird when things are not done perfectly in sync with the gating pattern.

Anyway, this is just what I’ve found in my quick little experiment.

PS. It wasn’t the actual audio output clipping. In fact I had the volume fairly low, definitely not 100%. I’ve taken a screenshot from the rendered .wav in soundforge, and you can quite visibly see the problem.

It still clips even at the lowest volume level (btw I ALLWAYS use Autoadjust mastervolume)…

Yes I got the click also now. On volume, as dblue said. Before
I tested only on beat notes.

There is a knob called “countour” that adjusts the attack/decay of the
gate and if you decrease that knob, the click goes away. As if
vanguards “hard” gate function produced the click when going from
“off” to “on”.

And you’ve tested this in Cubase aswell? Have you reported this to reFX? If not, please do so… :)