Visual Bug/Glitch

Ok this just happened to me. 'Was making this tune here and decided to grab a guitar to jam along. So I sat on my bed started to play. After a while (like a minute or two) I looked back onto the screen and saw this. Only the left side of the screen responded to mouse clicks, as if the window got compacted half sized horizontally. Resizing the window made it go away.

Nothing serious or anything, but just thought I’d give heads up. Not even sure if this is Renoise specific, but anyway…

That looks like a video card problem.Have you airdusted out your system quite recently? What platform are you using Renoise on?

Yes it might be a video card problem too, but I haven’t experienced any other problems. I actually dusted it like two weeks ago completely. It’s running at completely normal temperatures. Renoise is running under 64-bit vista.


do you have any energy-/screen-saver active?
and check you monitor too.

I have screensaver, but it activates after 15 minutes, and the computer was idle only 2 minutes tops.

Any suggestions how to and what to check about my monitor?

sorry, I wasnt clear enough.

nvidia or ati? crt/lcd dvi/vga

so if its a crt type e.g. try the demagnetization and check if the monitor is warming up a short time after trigger the power switch.
or maybe you have a vga/dvi converter that is broken.

otherwise, if you have two dvi connectors (for multi-monitorsystem) try the other one.

do you tried to change your nvidia detonator or ati catalyst, already?

ATI HD4850, not overclocked, semi-recent drivers, two flat FullHD monitors both connected with DVI.

I don’t think it’s a problem with the connector or such since only Renoise was experiencing this glitch. It could be that my Radeon is falling apart, I’ll have to look into that, but in case it is a bug in Renoise I thought I’d just report this.Obviously if it starts happening with other programs then it’s a driver / hardware failure.

These kind of cosmetic errors are usually really a GPU card problem. Renoise does use DirectDraw to render its GUI frames.
I think your problem might also occur in DirectX games, but i don’t know if you play games on that machine (i suspect it noticing the type of card you have in it).

There is one switch in the GUI preference options that might affect the problem: Try to see if you notice changes if you toggle the “More compatible gfx” updates.