Waldorf Edition 2 just Waldorf Attack doesnt work

Hello everybody!

This is my first post - I hope someone could help me 'cause im getting really desperate :smiley:

I just bought the Waldorf Edition 2 from their website. I really had/have problems to get things work. What I did so far:

  1. bought it from the website

  2. went to their download center

  3. installed the Waldorf 2 thing

  4. give “access with admin rights” to the folder (“Steinberg”) in der Programme (x86) folder

  5. set the path for VSTs in Renoise

Now i can use de D-Pole Effect and the PPG Wave synth properly. I also can load Waldorf Attack but it gives me just some “click” sound, I cant use any modulation with the external editor and cant load any presets or if i do, the sound doesnt change. Im surprised that the D-Pole and the PPG are the 32bit Versions (this i can see in renoise) - because I downloaded and installed all files while i was guided through the installation. When I try to get the .dll files of the VST instruments from the normal “Programme” folder (when i change the path in renoise), than renoise cant initialize them …

Im really stuck and some kind of frustrated because I just bought that very cool VSTs … So I hope someone could help me. :slight_smile: until then i can go outta space just with the PPG ^^

Thanks a lot;



I just tried - delete everything, reinstall Renoise (64bit) and Waldorf Edtion 2 again but just selected the 64 bit VSTs. Now I have to say to Renoise that it has to grab it from the normal “Programme” folder (making it free again with admin rights) and again, it cant initialize it.

I think it may be a problem with administrator access, that renoise is unable to access the folders it needs, at least that seems to make things problematic sometimes. I assume you use Windows?

I suggest you try running in administrator mode and see if that helps. You can also try to install the files outside of the ‘programme’ folder to somewhere you have full access, create a folder 'VSTplugins’or whateveron the C: drive.

I’m running the Waldorf Edition 2 x64 and PPG3 x64 and all plugins work like a charm here (Win7 x64). To prevent the issues with admin-rights of several plugins (e.g. Cakewalk plugins are candidates with similar problems) with activated UAC I’ve excluded my VST-folder from the Program Files-Folder and moved it to the root [edit: like TheBellows already said]. Depending on how many VSTs you’re running, this might become a crapload of work, but I’ve never ever again had any issues of that kind. Imo well worth the work.

Have you tried to run the Edition-Installer as Administrator (“run as administrator” via context-menu) already?

Running Attack 2 64x just fine in 3.1. My vst folder is not in the default location.

Thanks a lot for youre answers! :slight_smile:

Unfortunately I couldnt fix my problem. What I did:

  1. I deinstalled Renoise and all of the Waldorf stuff

  2. I reinstalled Renoise (64bit Version)

  3. Downloaded the Waldorf Edition 2 from their download section: Waldorf Edition V 2.2 LE - VST VST3 AAX - 32 & 64 Bit (WIN)

  4. then I was right clicking the windows start button and chose “Eingabeaufforderung (Administrator)” (sry my english is bad ^^)

  5. I entered: net user administrator /active:yes

  6. switched the user to “Administrator” (didnt know that this is even possible ^^) so then i was logged in with the admin account

  7. I installed the Waldorf Edition; all files

  8. I opened the “Programme” folder and then i right clicked on the “Steinberg” folder to open the “Eigenschaften” (“Properties”)

  9. now I selected “Security” and pressed the “bearbeiten” (“config”) button

  10. now I selected everyone from the list (trustedinstaller, user, admin) and allowed everything to everybody by ticking all of the boxes

  11. After that I started Renoise, chose the “Steinberg” folder as VST directory and it could load the VST

  12. then when I try to run them, Renoise cant initialize them

  13. again: when I do the same with the steinberg folder from “Programme (x86)”, then I can load the instruments - but attack has again just one nasty click sound.

After that, I tried it the other way by following youre advises and chose other install directorys for the Waldorf Edition (for example: "this PC -> C: -> user -> rs -> Musik -> Plugins), where I have all my Plugins. I made two new folders there so I can chose one for the 64bit and one for the 32bit. When I try to load the 64bit files, Renoise says it cant initialize them. When I load the 32bit files I have again just a problem with the Attack VST.

While I tried these different things, UAC was disabled.

My Computer: Windows 10 Pro, Intel® Core™ i5-6200U CPU @ 2.30 GHz 2.40 GHz, 64-Bit-Betriebssystem, x64-basierter Prozessor

I was wondering why (after reinstalling Renoise) Waldorf didn’t want to know validation code and email adress again. Could it be that the 64bit versions are blocked by something like this?

I am also not sure if I did the things with the “admin” rights correct … ^^

Does anyone have another idea or knows what I am doing wrong? I also wrote to the waldorf support, but they didn’t answer yet.

hope everybody is enjoying their weekend with nice music production :smiley:

i bought this too, i will chekc it out and get back to you

It works fine for me - win 8 64 bit

VSTS not in default location

Okay … thanks again.

I just wrote to the Waldorf support, but they say they can’t help me because they do no testing on Renoise haha :smiley:

Am I missing something with the download and validation?

File from the download section:

Waldorf Edition V 2.2 LE - VST VST3 AAX - 32 & 64 Bit (WIN)

I validated (entering email adress and validation code) it once when I first loaded it into Renoise. After deinstalling/reinstalling the stuff, Renoise (or better said the plugins) didn’t want to know my code and email again …

still desperate :slight_smile: still hoping ^^


I had contact with a renoise supporter discussing and trying several things … but again: nothing worked.

At the same time, I contacted an employee from waldorf again. This time he offered me a team viewer session. After one hour trying to make the plugins run on the ableton demo or renoise, he/we gave up. It seems that something is completely fucked up with my admin rights. He stopped at this point, because he could have made damage to my computer. He recommended to reinstall windows again.

I did that. Plugins from Waldorf are still not running :smiley: … every other vst plugin I have works perfectly. I still don’t know whats goin’ on. :smiley:

But Wayne. I ordered the new macbook pro this week … muahaha