Waves Morphoder VST doesnt restore some Parameters correctly


so as we all know i need ages to finish a song. yesterday i was demonstrating a mate some of my tunes for some upcoming projects.

i’ve loaded a song into renoise 2.0RC3 which has been saved with renoise 1.9.1
back then i also had to do some automation fixing again. and now again.

WAVES MORPHODER does NOT load with the correct saved fx automation parameters as they should load.

this is a very odd problem. the .rns version has the original parameter automations.
the xrns doesn’t. here some pictures:

it seems that renoise itself has moved the order of the
effects parameters.

and i’ve had this problem before and told you guys about it.

another bug is that v2.0RC3 AND RC4 do NOT load filterVST (antares) anymore.
i’ve re-installed the plugin and RC3 still doesn’t load it.

odd part about this? … renoise v1.9.1 is loading it flawlessly!

so just don’t release it as final yet as there are problems to be solved and you want a clean cut release, right?

i’ll do some more testing and let you know!

Hi Teis,

Sorry, but you can not expect that we fix these problems some minutes before a version goes final, at least not without giving us more details about the problem. Are you sure that this is a Renoise problem and not simply a bug in the VST?

You have you never responded to the other unreproducible VST problems that you’ve reported. We’ve tested this release for 4 months and have to stop at some time. Whatever we do you will always have problems, crashes and other kind of problems with VSTs. VSTs are programs on their own which of course also have bugs.

Moved to the general reports&help section. We’ll have a look at this for an upcoming release…

hmm ok. but still it does not load the antares filter vst plugin. even with a clean renoise isntall it doesn’t wants to load that dll :frowning:

Application: Init…

VSTPlugs: Searching for new VST plugins in ‘e:\audio\steinberg\vstplugins’…

VstPlugs: Trying to instantiate e:\audio\steinberg\vstplugins\FilterVST\FilterVST.dll
VstPlugs: Instantiate FAILED (failed to load the DLL)