Waves plugins not working

‘Try remove CachedFailedVSTs_x64.db and CachedFailedVST3s_x64.db in your preference folders and do a rescan.’ This is not a solution before anybody suggests it.
I was onto waves support,I uninstalled everything including renoise,worked the first time,failed after.Anybody else having problems?

You know we are many that have trouble with Waves, nothing new… A long time ago I bought one of their large bundles (v9 legacy) and was enjoying it but then I got a new computer and shit hit the fan for some reason and I quit using their plugins for a long time as I couldn’t get it installed, then one day I tried to fix it and used probably 6 hours to do so, infuriating but I got it to work, unfortunately I can’t remember exactly what I did so here goes my thoughts…

Install the legacy version first if you have those old plugins. I think maybe there are versions of a plugin that are too new for your license, maybe that can cause confusion if you try use a v11 version but only have the v9 license?

Be sure to activate the plugins.

Install and update Waves Central and install your v10+ plugins there, be sure to activate them before running Renoise or I think you’ll might have to remove the infamous “CachedFailedVSTs_x64.db and CachedFailedVST3s_x64.db”.
I had to constantly remove these files when I was experimenting.

Now what I did in the end here was to make sure I only had the Waveshells in one VST folder, so I manually copied the files below to my VST folder (maybe there’s a V13 too):

WaveShell1-VST 9.92_x64.dll
WaveShell1-VST 11.0_x64.dll
WaveShell2-VST 11.0_x64.dll
WaveShell2-VST 12.0_x64.dll
WaveShell2-VST 12.1_x64.dll
WaveShell3-VST 10.0_x64.dll

But yeah, it sucks! GL

1 Like

Ok thanks,i will give this a try.

So, I’m gonna go on record and say this is a Renoise issue. I’ve tried every suggested method, including downloading each waveshell all the way back to V7, and nothing has worked. Remembered that all my waves plugins use to work fine on the previous version of Renoise, so I went back Renoise 3.2.0 and all my Waves plugins worked swimmingly with Waves 13 (V13). This is definitely a Renoise issue, but I’m sure they’re working on it. As much as we’ve complained about it, I’m sure they’re trying to figure that out.

Now I gotta figure out how far back do I have to go before I can get Arturia’s Analog V working properly. I wanna say, there was magical time when I could use Arturia and Waves, but I think that was Renoise 3.0.

Haven’t got any issues using Waves or Arturia with Renoise here.
Running Windows 10 and latest Renoise.

Untitled

Wait until they do an update then you will… I have no problems with Arturia though,in fact their plugins seem to work very well for me including updates and all that.Waves though are atrocious for me.

Arturia plugins run fine but some of their plugins do have GUI glitches once in a while, Waves on the other hand has always been a pain and i can’t even open Waves Central after many months, they have made their system with different versions and waveshells overly complicated and that is probably what’s causing all sorts of issues.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.