Waves plugins on Windows 10 64-bit with 3.1.1


(SyneRyder) #1

Has anyone got Waves v10 plugins working with Renoise 3.1.1 64-bit on Windows 10?

I can get AudioTrack & Bass Rider to load, but Renoise seems to crash once it tries scanning Bass Slapper (which is a virtual instrument, not an effect). None of the other Waves plugins are showing up. My Waves plugins work fine on Renoise 3.1.1 Mac with High Sierra 10.13, but I’m trying to move to Windows.

I’ve tried deleting the VST caches & CrashedVST caches & rescanning, but that hasn’t worked. I’ve also tried the shell2vst trick to make Waves plugins work, but shell2vst also stops at the Bass Slapper VST instrument. I’m just left with “hell3-VST 10.0_x64” and “hell4-VST 10.0_x64” in my effects list. Moving the “Bass Slapper.bundle” or removing my Bass Slapper license & rescanning didn’t help either.

(For what it’s worth, Cantabile Lite doesn’t load Bass Slapper or any other plugins after it either, so I guess this is really a Waves problem… but I thought I’d try asking here first.)


(Garf) #2

Yes, I had their plugins working just not AudioTrack and Bass Rider, unfortunately I can’t remember exactly how I got that shit to work, think you have to copy the WaveShell dll into the correct VST folder, they have instructions on their website somewhere… here: https://www.waves.com/support/how-to-use-waves-plugins-when-using-custom-vst-folder

Unfortunately I’ve installed hyper-v (virtual machine) afterwards and now the plugins can’t authorize anymore, Hyper-v change the network interface and I can’t disable that. So I just say fuck them plugins!


(SyneRyder) #3

I feel your pain - my Mac had so many repairs last year that Apple replaced the motherboard, which meant reauthorizing my Waves licences & trying their once-a-year automatic license retrieval option (as well as relicensing all my App Store software too).

I had Hyper-V installed on this Windows machine, but I think I removed it in favour of VirtualBox & VMware… unfortunately neither are as good or fast as Parallels Desktop was on the Mac, so I’m still looking for good VM software on Windows too…

I’ve already got the WaveShell dlls in the right folder, but that didn’t help. The standalone versions of Bass Slapper, Electric Grand 80 and GTR aren’t working either, so I might have to ask Waves support.


(SyneRyder) #4

An update for anyone else who has this problem, uninstalling all the v10 Waves plugins (via Waves Central), then reinstalling everything except Bass Slapper seems to have worked. Might just be a problem with the new Bass Slapper plugin, or maybe I had a corrupt install.

To rescan correctly, I had to delete the Renoise plugin cache:

  1. Go to Help -> Show The Preferences Folder menu
  2. Quit Renoise
  3. Delete the CachedVSTs_x64.db and CachedFailedVSTs_x64.db files in that preferences folder
  4. Relaunch Renoise.

If your Renoise isn’t set to rescan plugins automatically, go to Edit -> Preferences -> Plug/Misc and click the Rescan button. I had “Rescan previously failed plugins” and “Run all plugins in sandboxes” checked, but I’m not sure if that’s necessary.

The Gold + RenMaxx bundle takes so long to scan that Windows thinks Renoise has stopped responding, but if you keep clicking “wait for program to respond” it will get there. I can’t imagine what it’s like for anyone with the Mercury bundle…


(system) closed #5

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.