Windows 7: Cannot Execute Script In Script Editor

Thought I’d take a look at the scripting but could not get too far. Tried copying this simple script to the editor

i = 0  
for pos, line in, 1) do  
 i = i + 1  

Hit “Execute” and nothing happens. The Terminal window is empty.

Rebooted into my old (but faithful) XP partition and did the same and everthing worked as expected. Is this a Windows 7 specific bug?

This prints 12345 in the terminal using win 7 64 here.

will the script editor just do a simple print for you? i.e.


Yes, if I enter one statement in the terminal command line it works.

If the script executes on your Win 7 64 it must be something about my system then <_<

Where have you pasted this to. When pasting this into an existing xrnx, then nothing will happen. This will only reload the tool.

Try “any” other file which does not belong to and xrnx, like the “TestPad.lua”.

It works if I paste it into TestPad.lua

But if I create a new file (/User Scripts/Tools/ right click > Create new file) and paste it in it does not work (although this is what worked on XP)

Edit: Forget what I said about XP. Just checked it again and as I had not installed any scripts the Tools directory was not showing so is was just running from User Scripts/

So all script development should be done outside of the Tools directory?