Windows: Audio In Other Programs Stops Working

After running Renoise 2.5b3 all of the audio in my other programs will not work. The behavior is quite interesting.

  • VLC Media player will crash trying to load an audio file.
  • Audacity will load an audio file, but will crash when I try to play an audio file
  • WMP 10 will crash trying to load an audio file.
  • USB mic won’t record anything

In general my system becomes mute.

Renoise continues to work, I can open it, play a song, close it and come back and there are no problems with Renoise, but the other problems continue.

When I shut down my computer, the windows closing sound plays (no system sounds play like mouse clicking before that point).

I do not have the problem with 2.1.

Event Viewer shows nothing but the Application Hang messages from when the above programs stop.

The odd thing, is sometimes after using my computer to do work and stuff I’ll find that the sound has inexplicably come back. For example I just did windows update and all of the sudden my sound started working again.

Windows XP sp 3.
Tascam US-122mk II audio interface
Oxygen 25
3 gb RAM
AMD 5400


Do you really mean after having closed Renoise, or while Renoise is still running?

On Linux Renoise uses the soundcard exclusively, blocks it for other applications to get a somewhat acceptable latency & Audio performance. This also has not change during the last Renoise release including Renoise 2.5.

Or did this only happend once to you after running Renoise and now just works fine when trying this again?

Did Renoise correctly shut down in those runs?

Does the same thing happen when you for example run Ardour other other music apps which exclusively use ALSA?

Linux: Alsa… System: Windows XP sp 3.

Sorry i don’t understand how ALSA can interact with WMP10 ?

Oh, my fault. I somehow implied its Linux, just because this problem is a usual Linux prob. Sorry.


Are you using ASIO with Renoise then?

Did Renoise correctly shut down in those runs? You can check this by opening the taskmanager and lloking for “Renoise.exe” after having it closed.

Does this always happen or did this happened just once?

The Tascam driver may have crashed for whatever reason.

After shutting down renoise, Check if it’s still active in the task manager , if it is , this means that it still uses your asio driver ( if you use asio ), therefore other programs will not be able to use the driver …(this is bugging me since 2.1…)
But then again …if this is the poblem you shouldn’t be able to open a second instance of renoise,because the first instance is using the ( unreleased ) driver .

Shoot I didn’t see this got moved here.

  1. Foud out it happens once I start Renoise not after I stop it.
  2. It isn’t in task manager after I stop it. Renoise correctly shuts down.
  3. I am using ASIO
  4. It always happens.

The following is a log of everything I did:

  • Rebooted computer
  • Launched Renoise 2.1
  • Played some sounds with VST Renoise 2.1
  • Closed Renoise 2.1
  • Launched IE, played flash game: sounds work
  • Opend a song in VLC, worked.
  • Launched Renoise 2.5
  • VLC continnued to work
  • Played some sounds with VST in Renoise 2.5
  • Close and reopened VLC and WMP, both still worked.
  • Played Flash game in IE, sounds no longer work
  • Sounds no longer work in Silverlight Apps either
  • Rebooted computer
  • Launched Renosie 2.1 and played some sounds and closed.
  • Did VLC and Flash game all ok.
  • Launched Renoise 2.5
  • Flash game sounds and Silverlight game sounds don’t work.
  • Launched VLC, doesn’t hang, but doesn’t play sound either.
  • Close Renoise 2.5
  • Launched WMP and VLC does play now.
  • Launched flash game and it works too.
  • Opened Renoise 2.5 and played some sound
  • Opened VLC and didn’t stop but wouldn’t play sound.
  • Closed Renoise Opened VLC, worked again.
  • Started VLC and played a song. Then launched Renoise 2.5. VLC started playing faster pitched and skipping. Renoise sounds fine when I play sounds on keyboard.
  • Changed Latency to higher on Tascam US-122 control panel. VLC was still skipping, but differently.
  • Closed VLC and reopened, would no longer play (again didn’t hang). Neither would WMP.
  • Everything closed, opened Renosie 2.1, opened a song in VLC. VLC would not play. IE sounds didn’t work.
  • Everything closed, opened Renoise 1.9.1, opened a song in VLC. VLC worked while Renoise was open. IE sounds worked while Renoise was opened.
  • Rebooted
  • Opened Renoise 2.1
  • Opened VLC, worked fine.
  • Opened IE flash sounds not work.
  • Opened VLC again, stopped working.
  • Closed Renoise 2.1
  • Opened Renoise 1.9.1
  • Tried to load a VSt. Absyth 5 said under instrument. No VST would work.
  • Opened VLC it worked fine.
  • Sounds in flash game work fine.
  • Close Renoise 1.9.1 and wondered what was going on here?

The problem in diagnosing this is trying to figure out who is playing badly. I don’t have any other problems in any other audio software that I use, but really I use Renoise a million times more than anything else. Obviously it is something with the Audio Interface and Renoise. It seems like this might be a problem since Renoise 2.1, but I just noticed? I haven’t been using too many samples as of late so it never must have come up trying to get samples while Renoise is still opened. That being said I never ever noticed any problems after using Renoise until I got 2.5.

Anything I can do to help diagnose this?

Beside of this:

I don’t really have an idea, beside that the Tascam audio interface driver simply might be buggy.

Have you already tried reinstalling/updating it? This only happens with ASIO, right?

Renoise isn’t active in the Task Manager after it is closed. I don’t have a problem when I use the DirectSound drivers.

I’m going to send a message to Tascam about this, because if its only me that’s having the problem then it has to be the audio interface. Though I know little to nothing about Hardware, I do see that the problem gets exaserbated the more I use Renoise (if I open play some sounds and close then everything else is fine, if I have a crazy song that I work on for an hour, then mysteriously my sound on the rest of my system comes back an hour after I’m done with Renoise).

That being said, I do have one conclusion after all my screwing around:
1.9.1: I have no problem with anything. I can load a crazy song, play it forever, and play audio elsewhere simultaneously all of it is kosher.
2.1: I have the problem.
2.5: I have the problem, and it is worse.

Maybe something like PDC is where the problem occurs? I don’t know.

Good job with 2.5 I am very happy with it.

Yust a thought …you might want to download process explorer which is a task manager on steroids, after quiting renoise you can see which process are active in process explorer ……s/bb896653.aspx

Nothing interesting comes up with process explorer. Thanks for the tip though.


One new interesting development, though I don’t understand it. I can watch television on my computer via WinTV while running Renoise 2.5c. No problem with the sound whatsover even while playing a CPU intensive song.

My guess is that the streaming audio from WinTV takes a different path (a low level straight to the hardware) than other applications (using some function of the OS) so that whatever Renoise is doing isn’t conflicting.

Sounds like a buggy audio driver to me. Check for an updated driver or try using the generic windows driver and ASIO4ALL.

If you use Asio with Renoise, you probably are lucky enough to be able to use Directsound drivers and ASIO at the same time.
More applications can use the DirectSound driver at the same time with less or no problems. With ASIO drivers, this differs from soundcard to soundcard.
My soundcard’s ASIO driver does not accept any secondary application, using it’s resources when the primary application already processes it, not even DirectSound in a parallel sense.

Final report:

Probably nobody will read this, since it is in archive. I recently upgraded to Windows 7 and still had the problem (worse in fact). The only thing that works in using the ASIO4All drivers. So it is for sure just crappy drivers.

I’ve been holding back but I’m going to bad mouth this product since it is for sure for sure their problem.

No, it is not only you experiencing this kind of stuff with ASIO. I have similar problems with my soundcard but this already was so from the very beginning and i also experience this in other audio applications that use my ASIO driver.

ASIO drivers are higher demanding on their own audio-resources and Renoise tries to exclusively make the best use of their power.
I guess your ASIO driver is now better “Exploited” with the new 2.5 engine than with Renoise 2.1 and 1.9.
Steinberg use their own ASIO drivers. Whatever voodoo-magic is put in it, is not known, but they seem to work more effectively in thread sharing than the original manufacturer drivers.