Windows: Midi Out Timing/Jitter


First post. I’ve spent a few hours with the renoise demo on my windows laptop using only the onboard samplers and fx and I really dig the workflow.
But in the end I was hoping for it to be my new main midi sequencer for triggering my hardware samplers and synths. So right now I have it installed on my studio PC hooked up via MIDI to an akai sampler and unfortunately the midi jitter is really bad.
I am coming from reaper and reaper’s midi out timing isn’t the tightest either, but after a few tweaks (e.g. lowest ASIO buffers) and avoiding a few features (e.g. no item looping) i can make it work ok. Also I spread stuff out to several samplers, each with their own midi port, which helps a lot, too.

But the test I’m doing right now is a simple monophonic 1/16th note pattern sent to an akai s3200 and it sounds all over the place. (both on USB MIDI and the MIDI OUT of my RME AIO, makes no difference)
Unfortunately the demo does not let you use asio, so I can’t check if that’s the issue.

Am I doing something wrong here? I found a few other threads discussing midi timing issues with renoise, but they’re old. Also I see videos on youtube where people are sequencing their hardware with renoise and it sounds fine.
I was ready to buy a licence, esp. since the pricing is very fair, but the midi jitter I am currently getting makes it useless for my application.
Any help? thx

Maybe you could help out here: MIDI timing in Renoise is bad when getting sequenced externally (by Cirklon 2) - #47 by gentleclockdivider

There are some midi related fixes planned for the next release, which is currently in work.

Oh, that’s great news.
I will post audio examples of my problem there, but I’m not sure if it is going to be well received since the topic seems to be more about renoise’s midi in performance.

I think it’s not a problem @taktik will split this, if needed.There was also a discussion about problems with internal midi out between VSTi’s, which was split out later. It’s also on the todo list for the next release. So its the perfect time to bring your issue to the table, too. So the devs wont miss this.

1 Like

Of course I was kindly informed, that my post is OT :smiley:

I’ll leave my audio files here as well.

reaper_vs_renoise_midi_out.xrns (2.3 MB)

1 Like

Its not really OT. Could be possible that the code for handling midi in share some code also for midi out stuff. You’ll see if one of the dev teams responds.

1 Like

I agree. The architecture regarding buffering etc will most likely have some similarities.

This indeed is a different problem/topic. Let’s not mix those discussions please.

What are your audio settings in Renoise you’ve tested this with?

MIDI output timing indeed and unfortunately is quite a pain to get right on Windows, compared to OSX and Linux where it usually just works, as there rarely is driver-side MIDI event scheduling available and applications have to work around Windows high timer resolution. I hope this changes in future, as it did with WASAPI for Audio in Windows 8.

In general: as you already did in Reaper, using small buffer sizes and ASIO will improve the MIDI timing in most situations. The smaller the latency/buffer size, the more stable the MIDI output stream should get on Windows.

If you can’t test with ASIO in Renoise, I can create a version for you which does, so you can test out if this solves the problem for you. Please contact drop us a mail at support @ renoise if you’re interested.

1 Like

I’ve just managed to steal my wife’s macbook and install the renoise demo. Midi’ed up my S3200 via the same ESI M4U XT interface and it sequences perfectly fine.

So this must be an issue with DirectSound (the only option I have available on the windows demo) and its large buffersize. Btw the latency setting im ms did not have any kind of effect on the midi timing.

I’d love to try ASIO but I can’t since the demo does not allow it … not sure why to be honest.
I also don’t quite understand why midi has to be tied to audio buffersizes, but I am no windows developer. I am definitely going to read the link you’ve provided about windows timer resolutions.

I’ll drop you an email. I’ve been spending quite some time with the demo version so far and I love it.
If I can get it to have decent midi performance on my PC I am getting a licence asap.

Thank you

1 Like

Just to be sure, you have set the mode as “LineIn Ret” in the midi tab of the instrument editor instead of “ext. MIDI”?
That makes a big difference when triggering your external gear and listening back through a line-in device.

This indeed changes the timing but should not affect the jitter. I’m already in contact with ev0 to sort out the jitter problem. It’s a Windows specific problem which we’re already have a /so far promising) solution for.

Just to make clear what those “modes” are for:

LineIn Ret mode does not delay the outgoing MIDI events by the current audio device latency. So when you’re feeding the externally triggered synth signal back to Renoise, the synth’s audio signal gets aligned with Renoise’s internal audio stream.

ext MIDI does delay outgoing MIDI events by the audio device latency. This is necessary when you’re mixing the sound output of the synth and Renoise’s output with an external mixer, so Renoise’s delayed output signal gets aligned with the external synths output.

1 Like

Just wanted to report back that using ASIO the MIDI timing/jitter I get is perfectly fine. So the issue was simply related to DirectSound.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.