Windows: Native Instruments effects plugins UI not working with Windows display scaling is set to 125%


Dell gen 9 i5 with Intel HD GFX
Win 11/Win 10
Renoise 3.4.1

The mouse bounds don’t match up with the UI bounds, it seems that this occurs with any Renoise scaling whenever the Windows scaling is not 100%, I have my WIndows scaling set to 125% and that is the image below.
No difference at whatever scaling is used in Renoise, sandboxed or unsandboxed.

As the title says, the UI is in the lower left of the plugin window and the controls do not work, it passes audio and the effects are working if you hit randomize to hear the parameters change, but they can’t be adjusted.


What OS?
What Renoise version?
Are the plugins running in a sandbox? Does enabling/disabling help here?
Does it say anything in the log?
Did these work in other Renoise versions? Any particular gui, scaling settings used?
Anyone else having these plugins can confirm the problem on their set-up?

I don’t have issues with these plugins on latest Renoise (Scaling 125%), Windows 10 (Scaling 100%) and latest Nvidia driver as well.

Little sidenote: I found out that NI plugins usually tend to contain poor quality code / poor technical conception. I always wondered why more recent NI plugins produced a crash on my hackintosh system. It turned out that NI plugins use a very crude / not clever way to search IORegistry tree to find the active graphics device. If the used value in the DSDT/ACPI is not exact matching the pattern that NI expects here, the plugins won’t find the primary device correctly and crash (even though the gui then is normally displayed). This plus the way they are unable to manage a proper GUI code since 4 years or so, also are discontinuing good plugins, leaves the impression at least to me, that the code quality is very low at NI.

Win 10 and Win 11
Tried all scaling options
Tried in and out of sandbox
Latest Renoise
Gen9 i5 dell laptop with intel HD GFX
They work fine in Reaper/Sound Forge

Edited first post with the cause, it is caused because Renoise is ignoring Windows scaling, at windows scaling 100% (Not recommended) it works.

If you disable the auto-scaling in Renoise’s plugin option, this may work as well:

Try disable the “Auto-Scale extern editors” option, then unload and load the plugin again.

Reaper does no auto-scaling by default, that’s probably why it works here.


Yep that fixed it, strangely it is not HIDPI screen though, its just a HD on a laptop.
Is that a newly added option, I have never even noticed it before?

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.