Windows: Renoise Loses Usb-Midi Keyboard Connection

From time to time Renoise loses connection with my MIDI keyboard (windows7,emu xboard61). After this I have to:

  1. close renoise
  2. restart keyboard
  3. start renoise
    Step 2 is mandatory - if keyboard is not restarted, Renoise don’t play sounds. What is interesting, program is aware that keyboard is plugged in as it lists it in midi devices list. However, it don’t play. I don’t use any drivers since USB-MIDI works out of box in Windows 7 (in linux too, btw.)

Hey carmazine,

that you have to restart Renoise to reconnect USB MIDI/Audio devices on Windows unfortunately is expected. Windows does not support hotplugging of MIDI/Audio devices.

So the question is why your devices looses the connection randomly. I don’t think this is a Renoise issue though. If it would, a lot of people here would have the same problem with the generic USB drivers. This definitely is not the case.

Only thing i can think of as reason is either a hardware problem (broken cables, broken device) or broken drivers.
Could you please try to exchange the cables and check if there are custom drivers for the emu xboard61?

Hello :) Thank you for quick reply, as usual. Great support we have here!

I see, it’s a shame though.

The same keyboard behaves rock and solid with Linux so I don’t think it’s a matter of hardware or cable. I will check the EMU drivers. I’m not sure if they support windows 7 though… some of their win7 software is still beta … what a shame :)

Just out of curiosity, have you tested your Emu 0404? I’ve not had the chance to use mine on my lappy yet and I noticed their W7 drivers could be somewhat dubious.

I also experience this. The disconnection occurs after resuming from sleep and the controller won’t be detected by any software. So definitely a Windows/Hotplugging issue rather than Renoise.

I didn’t because I have PCI version which I use with another computer with archlinux.

Update: I was using midi keyboard under windows xp for couple of days and it worked fine so I assume it is a Windows 7 / driver problem.

This is why I dislike sleep functionality - almost everything fails to work after waking up or behaves unpredictably.

I have this problem also. Out of nowhere my midi keyboard just stops working…

i think partially it’s because of the sleep functionality. i cancel all those options and put everyting at always awake/max consumption hehe.

besides the standard poweroptions in your windows controlpanel there is another setting for powerconsumption regarding the usb-ports!

  • you need to go to your device manager (right click my computer and then properties or through the control panel)
  • within the device manager you see a list of devices and at the bottom (in my case) you have your “universal serial bus controllers” which stands for your usb-ports!
  • press the small + sign to open the list and i am not shure if every windows calls them the same, but mine has about 5 “usb root hub’s” when you right click one of those and select properties you whil get a new screen with a couple of tabs
  • the last tab is “power managment”
    -make shure the option “allow the computer to turn of this device to save power” is turned off on ALL your usb ports!

this one hidden setting has driven me crazy on my previous computer making my dvd burner dissapear when the computer thought it was time to shut down some usb-ports etc… weird how that interacted with my ide dvd burner :blink:

i hope this helps you out!