Windows: User interface scaling makes some VST GUIs bugging

Hello.
I noticed that when you go to renoise’s preferences and change the user interface scaling to more than 100% then when you open any VST it opens the vst’s GUI with some scaling problem. i attach to this topic a picture of how it looks like.
hopefully you can patch this small bug for the next release it would be awesome !
my OS is windows 10 and the version affected is the last one (3.2.1)renoise bug
cheers take care :slight_smile:
Dam

2 Likes

The HiDPI support on Windows unfortunately is a mess and there’s not much we can do here apart from trying out a few workarounds.

When plugins don’t “fully” support HiDPI screens you can either

See also
https://tutorials.renoise.com/wiki/HiDPI_and_UI_Scaling#Using_VST.2FAU_Plugins_on_HiDPI_Displays

Thanks Dam and taktik. I had the same problem.
Uncheck “Plugin > Compatibility Options > Auto scale external editor” working fine for me.

It is possible to set this option automatically for all plugins??
(For example … by editing a configuration file for Renoise …)

R.

1 Like

Unfortunately the option is required for most old plugins to work correctly, and there is no way to automatically set the option. We’d else had done so.

Over the time we’ll collect a list of problematic plugins and set the options manually in a whitelist.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.