Windows: x-fer serum VST > renoise GUI/Keyboard lags?


(gentleclockdivider) #1

I tried this synth about 1 ago , on a underspecified machine …aware it was a bit of a cpu munger , the gui of renoise also lagged …

Now …I am trying it again on fairly modern i5 ,good enough nvidia graphics , win 8 , renoise 64 …plenty of ram …iow fast enough to run some modern plugs

As soon as the gui is opened and played from the computer kbd , the lagging begins …it’s so bad …the note input data ( from the keyboard ) is not seamless ( dropping notes ) etc .

This happens when renoise isn’t even playing , just banging on the kbd is enough to make it lag

This DOES NOT happen with reaper , ( also able to use the computer kbd ) It runs smooth as butter

.This is a renoise specific issue , somehow the bussy graphics animation on x-fer serum …makes renoise lag …


(toimp) #2

Serum works perfectly for me, no problems here. Using renoise 3.1 x64 with serum x64 v 1.108 on windows 10 64x, i7 3770 cpu, an amd vga card and ur44 audio interface (directsound and asio works without problems).


(gentleclockdivider) #3

also when banging on the computah Keyboard ? no visual lag in renoise ?

Funny , maybe it’s because it’s the demo version of serum


(toimp) #4

What version number does the serum demo have?


(ffx) #5

Maybe something related to OpenGL and the graphics driver. EDIT: I just wrote this suggestion, because nobody will fix your problem in the next years. So try to fix by yourself.


(gentleclockdivider) #6

I just found out that this horrible lagging is ONLY happening when the moog filter is selected ., and only in renoise …heh

Verry strange , cause these don’t consume more cpu .

Nice synth , but I 'll remove it anyway…nothing that can’t be done with zebra/reaktor.


(ffx) #7

Does it disappear if you add a lofi device with constant noise directly after the synth?


(gentleclockdivider) #8

?

It just happens with the moog filter and some resonance , without reso and any other filter it’s smooth .

Moog +reso = can’t even play a simple triad on the comp.keyboard ,so slow and laggy .

Ah …the german filter seems to cause problems too .

Verry strange issue


(magickz) #9

hm. I never tried Serum. But, on their Serum website they write:

" System Requirements:

  • CPU with SSE2
  • Windows 7 SP1, or Mac OS X 10.6 or greater
  • VST2.4 , AU or AAX compatible host software." (quoted from xfer website)

Recently I had some strange problems with some Sonivox-Plugins, until I realized that their requirements specification

“Windows System Requirements: Windows 8, Windows 7 Service Pack 1 Home Premium, Professional, or Ultimate” (quoted from Sonivox website) does not include my Windows 10.

Solution was suggested by another Sonivox user. He told me to run the DAW in Windows 8 compatibility mode. (“To do this on Windows 10, just look at the Compatibility tab on the application shortcut for the DAW. Under Compatibility mode, check “Run this program in compatibility mode for”, then in the dropdown box, select Windows 8. Apply.”). It was the first time, that I heard about that possibility to run older apps in a compatibility mode. My Sonivox issue seems to be solved… This helpful Sonivox user told me, that Cakewalk plugins also have compatibility issues, but at least Cakewalk knew about this work-around.

Now I assume, that Serum’s requirements are exactly Windows 7SP1, all other versions seem to be not officially supported. I am not sure if that possibility also exists in Windows 8 (to emulate a Windows7SP1 compatibility mode), but maybe worth a try.


(gentleclockdivider) #10

My comp is about 5 years old , good nough for most plugins


(dblue) #11

Now I assume, that Serum’s requirements are exactly Windows 7SP1, all other versions seem to be not officially supported.

I think you can safely assume that Win7 is simply the minimum system requirement, and that its implied that all newer versions of Windows are supported.

I’ve got the full version of Serum here on my Win10 machine and have no major issues with it. No insane lag like gentleclockdivider is describing, with or without the filter enabled, whether smashing the keyboard or not, with or without Renoise playing notes while doing so, etc.

I’ve also successfully used the demo version of Serum on my older Win8 machine in the past, and had no major issues there, either.

Tested both 32-bit and 64-bit versions of the plugin, in both Renoise 32-bit and 64-bit, both bridged and non-bridged, etc.

I dunno what could be happening, but at least I’m unable to personally recreate it on my systems so far.


(magickz) #12

I understand. :mellow:

Serum looks interesting, maybe I’ll try it here, too…


(gentleclockdivider) #13

yes funny indeed , other then that it’s working great …

Just displaying the animation of the moog filter and german filter make it behave this way ,.all other filter types and gui animations cause no problems .

Anyway , I deinstalled it …


(strobotone) #14

I am also experiencing UI lags with some other VST plugins like Tone2 Nemesis and RayBlaster2.
Also Renoise´s UI is unresponsive when there are some animated elements in those VST plugin´s windows.

In my case the lags only occur with the 64bit plugins on Windows 10 in Renoise (v3.1.1).
But they are working fine on Windows 7 64bit with the same setup…


(ffx) #15

Have the same with some plugins using macos, too. I guess there should be a mode, a non-sandbox mode, but still running each plugin in an own process? or is that already a sandbox? e.g. Bitwig does run it in another process all the time, even if claiming not to run plugins in a sandbox.