Workaround For Ik Sampletank "performing Preanalisys" Hang

if you use Sampletank, you know that it has two annoying problems with Renoise:

1] LCTRL+INS (Renoise shortcut for pattern inserting) causes an useless info Sampletank popup to be shown

2] when loading instruments for the first time, a “Performing Preanalisys” dialog appears, and everything hangs forever

about 1, there is nothing we can do, but I have found a workaround for 2: give the focus to Renoise again, for example by pressing the save button (the floppy disk icon); this will unlock the window

Thanks alot ITAlien, i’ve been waiting for someone to get a workaround for this for ages!

Just one thing though: When you do that workaround, will the pre-analyzis cancel or finish loading?

glad to make you happier… the window apparently closes after reaching 100% status, so I think that the analisys gets completed

hey again, my extraterrestrial friend.

I’ve tried your workaround, and can’t get it to work.
And i’ve tried alot.


If you’ve got the 2.1 version (standalone) of Sampletank, you can load it up in Windows, and open each instrument and let them render. Now, they’re saved as already rendered, and you can open them in sampletank with no worries.

The only bad thing is that, since Sampletank has ALOT of instruments which needs rendering when opening them, this means you have to do this to most of them.

I believe this has been mentioned earlier though, but just thought I’d let you know, just in case.