[yup] Is Win10 officially supported ?

…I’m asking becouse Renoise doesnt work well on it for me… Looks like I dont have much luck with it.

On Windows 7 I had, never resolved, problems rewiring Reason to it (midi related freeze).

I moved to Win10, maybe too quickly, and Renoise really is playing up on it.

At first, I thought it was plugin related. I opened NI Monark and while switching from Renoise to Reaktor and back, I had serious audio glitches.

Then, I just loaded a sample and filled one pattern, and it did exactly the same.

I have NI Audio 2 DJ USB card and it’s very good for what I’m doing. It’s not a new PC but still quite capable - Q6700, 8GB RAM, NVIDIA silent GT520.

I suspect it is something related to graphics - the more is happening on the screen - the more audio glitches I have.

Some of you probably know about inintial Win10 / NVidia hiccups but I tried Monark standalone and Cantabile lite and both are running great without problems.

It’s a fresh install so I dont have much soft on it and just to be clear - I consider myself an experienced PC user - my system is really clean, without ANY silly shit running in the background.

What really is bugging me is that it’s only Renoise I have problem with - in the past - on Win7 and now Win10.

I have no problem with 8Y old Reason 4, no problems with FL Studio.

Is there anything I could try ? Is it possible to limit or disable GFX hardware acceleration use in renoise to test stuff and to make it usable before (and if) it will be improved?

Pretty strange. You can disable some GUI effects in Preferences -> GUI.

I did that already. I disabled effects, limited FPS. Nothing helped.

No driver alerts in device manager right? Renoise worked flawlessly for me on Win10, though I haven’t tried it rewired yet. I’ll try that when I get home from work to see if maybe that causes some weirdness.

Absolutelly no probs in device manager and as I mentioned, I tried some software already, everything works smooth, actually smoother than win 7, the overall OS responsiveness is visible better.

That rewire problem, it was in Win 7, not in 10, I didnt even try it in 10 having such fundamental problems with Renoise…

Currently setting up a windows 10 Renoise computer here, can windows 10 be optimized for audio use in general? I remember walkthroughs with past windows where you could set up stuff in the preferences like ‘background scheduling’, is this still recommended or not necessary anymore?


Which version of Reason did you rewire into Renoise? I still work with Reason 7 and have no performance or audio issues rewiring it into Reoise on my Win 10 system. I don’t think it’s a graphic performance issue. I still have my old Nvidia Geforce 9600 GT running inside this machine. All is working pretty well.

Astronut: maybe a silly idea, but can You try to disable vertical sync (is it possible overall/ for 2d destop on win?) in your graphics driver settings and test again? Is there a frame rate limit set in your renoise preferences?

Another idea (no idea if this can still happen, maybe outdated ) is to check your irqs in device manager: do the gfx card and USB port of your audio device share the same Irq ? If so, do u have any other card installed? If yes, put the other card in another slot and try again.

What power profile do you use? Make sure that you use “desktop” / full performance.

Well i ve got same framerate gliches, renoise by default with only native stuff used works well,another problem… A MAAFCKIN touchpad is not working at all, solutions from the internets wont help