Z3Ta+ 2 : Synced Lfo To Waveshaper Problem

Problem : when z3ta’s built-in lfo is assigned to the waveshaper & is synced, pressing play in Renoise stops the lfo automation and changing the waveshaper parameters manually has no effect on the sound whether Renoise is playing or not. If I let it play it’ll eventually start working normally again (after a few seconds to one minute depending on I don’t know what) until I stop Renoise and press play again.

To reproduce the bug :

  • start Renoise 2.7 or 2.8 & open z3ta+ 2
  • initialize the patch
  • choose whatever waveform and insert a few notes in the pattern editor, press play
  • in the lfo section : choose whatever waveform for any lfo
  • in the mod matrix : choose the lfo you picked for source, any waveshaper parameter for destination & select the range
    So far so good, everything works as you’d expect… now select a value for the sync in the lfo section, stop Renoise, press play again : now the waveshaper automation doesn’t work anymore and the waveshaper doesn’t respond to manual parameters change either.
    For some reason, it only happens with the waveshaper and regardless of what oscillator or lfo I choose.

Also I noticed, changing the “real-time quality” or “off-line quality” temporarily makes it work again.

Just to make sure, anybody else experiencing this or does it have something to do with my setup ?

I tried to reproduce it with a 32 bit version of Z3ta and Renoise b4 (also 32 bit)
but I don’t have any issue. Maybe I will try again tomorrow in my studio with 64 bit versions installed.

Perhaps fumble with the static buffering (usually people already do that the first) but perhaps disable the “Autosuspend” toggle in the instrument plugin panel as well?

I’m using the 32 bit version so it should be OK apparently. Would you mind upping a screenshot of your audio config or writing it here ?

Sorry, what’s static buffering ?
I’d tried the autosuspend thingy unsuccessfully.

Sorry Little late:

I have Static buffer thingy unchecked and the other 2 checked.

After some weeks working with 2.8 I do have a problem with the Arpeggiator.
it’s explained here: http://www.renoise.com/board/index.php?/topic/33541-z2ta2-arpeggiator-madness/

the arp seems to be steady inside Renoise lately for me, but Z3ta is always going out of sync when the song is played again from the beginning.
Maybe a zeta+2 (version 2.1) bug also. but really annoying while grooving with some one pattern tunes on the fly.

Has the same problem with 2.7->2.8 renoise upgrade. Try to change lfo phase.