zynaddsubfx . multiple outputs - how?

Having some issues here with zynaddsubfx .

Zynad is able to receive on 16 midichannels …

By enabling multi out in zynadd and renoise , each instrument gets it’s own output bus .

However , when resetting renoise ( stop ) the instrument is played on whichever track is focused , this should normally be overriden by the selected output bus .

The problem with the zynadd synth is , even when there are assigned outputs , the audio still goes to the focused tracks , which normally

should be overridden by the assigned outputs .


Edit I think it’s a bug in zynadd , reakto behaves perfectly with mulitple midi/audio channels from within one instance

All , o.K…now it works .

For those interested ,better leave the first output bus in renoise muted ,

The first instrument part in zynadd (midichannel 1 ) is automatically assigned to the second output bus in renoise .

I don’t think zynaddsubfx has support for this, I was asking the dev about this a little while ago and I seem to remember him saying each instrument cannot be routed to an individual channel, unless I’m mistaken.

edit: ok, how did you do it?

Yes it does ,

Download the latest windows beta .

Press the midi tab , there you’l find the button to enable the mulit out .

Renoise then shows 17 available outputs , the first one is reserved for the global stereo out , the first synth part of zynadd appears at out 2 , the second synth part at out 3 etc…

The first screenshot just shows the midi receive channels .

The secon one the enable multi output button