Activating Scripting Tools Help!


#1

Hi all,

This is my first post and it is probably going to sound ridiculous… but…

I have tried and tried to activate the tools within Renoise but really cant figure out how to do it!!

Its driving me crazy and me reaching out is my only option after searching on here for an answer… (Maybe I havent looked hard enough but I am pretty sure i have!)

By default Renoise has all scripting utilities hidden; to keep things as easy as
possible for those who don’t want to mess around with code. If you want to write
scripts, then the first thing you have to do is enable the hidden development
tools that are built into Renoise. This can be done by:

  • Launching the Renoise executable with the argument “–scripting-dev”

  • Opening Renoise’s config.xml file from the preferences folder, and setting the
    <ShowScriptingDevelopmentTools> property to “true”. This way, you don’t have
    to pass the above mentioned argument every time you launch Renoise.

This is what I cannot figure out… I have tried running all sorts of things using the terminal (Not even sure if that is even what i need to do haha)

I am on a Mac, Obviously any help would be very much appreciated as I am struggling lol

Thank you

Regards,


#2

What exactly haven’t you figured out? What exactly have you tried?

Have you located your Config.xml file?

Did it have that XML element?

Did you set the text value to true?

Did you try running Renoise from the command line with the–scripting-dev argument?


#3

Thanks for the fast reply!

Basically I’m not too familiar with running programmes from the command line, I tried a number of different things which I found online, thinks like…

“open /Applications/Renoise_regarding.app/Contents/MacOS/Renoise --scripting-dev”

I’ve tried many variations of this but none of them worked and I wasn’t sure that I was even going in the right direction with it!

I have tried to find the config.XML within the package contents of renoise itself… like I said not sure if this is where it even is…

Really frustrating as I have been using renoise for almost 8 years and never knew this scripting even existed untill recently and really want to dive in and try and figure it out with very little experience in scripting (clearly as I can’t work the terminal properly haha) but yeh… really want to figure it out!

Thanks for your help! Much appreciated


#4

Not on MAC here but this should work for you. Start Renoise, go to ‘Help’ menu and select ‘Show the preferences folder’, open the file ‘Config.xml’ with a text editor, search for ‘ShowScriptingDevelopmentTools’ and change the value from ‘false’ to ‘true’, so it looks like this ‘<ShowScriptingDevelopmentTools>true</ShowScriptingDevelopmentTools>’, save the config file and restart Renoise. Now you should have a new menu entry in the ‘Tools’ menu.


#5

Once enabled, this is what the tool menu should look like:
renoise_tool_menu.png?raw=1


#6

Just opened up the config.xml from theShow the preferences folderand changed the “false” to “true” like you said,

Worked a treat

thanks for the help!

Lewis


#7

I am also on a mac and tried to change the xml file, however, when I restart renoise the config file resets. Does anyone know why it is? I have managed to do this before.


#8

Kommandotolken: Just to eliminate something: You are modifying/saving the config file while Renoise is not running in the background? As a quit from Renoise may overwrite the config file, undoing your modification.


#9

I was having the same issue asKommandotolkenon PC.

Closing Renoise, then editing the file and saving, before relaunching Renoise solved the problem