Add autoseek to Sample Slicer

ok i have made a small test thingie,try and slice this,and notice that autoseek doesent get enabled to the sliced slices

Are you sure you have downloaded the version from the Xrnx repository in the link i pasted? (I haven’t updated the tool on tools.renoise.com, that is something i leave up to IT-Alien)

Also with your example, i can perfectly slice them with autoseek enabled:
Attachment 987 not found.

for ome reason it wont let me download from the link you pasted,when a press on sampleslicer i only get mainLUA and manifest.xml

when i rightclick i can download the file,but i cant drag n drop??

Autoseek is new, OK, but does it really have to be in the slicer GUI as an option? If I understood things right, all SNS wanted was that the original setting of the sample also gets copied to the slices? This makes sense and can also go without any option.

yes thats excactly what i meant,im sorry if i wasent being clear

I’m sorry, i forgot to mention that the google code site is a source-file repository, there all files are already displayed unpacked (not as xrnx archive but simply displays in their native folder)
You have a “Scripts” folder in your preferences folder (Help -> Show preferences folder) there go to Scripts\Tools\com.renoise.SampleSlicer.xrnx\ and copy the .lua file over there.

You might have to disable and (re)enable the tool in the “Toolbrowser” to allow it reloading the tool though, or enable the scripting-dev option so that you get an extra option in the tools menu called “Reload all tools” see: How To Manually Install Xrnx Files It is a bit more cumbersome method to do it manually, but it works.

ok first off how do i un-associate which program a file should be opened with??

second i cant install the files you updated,for some reason the manifest.xml is a much smaller size than it shows on the website,so when i overwrite the "older"files it wont show the sampleslicer in renoise,and i cant enable or disable it,it just disappears

using the latest version from XRNX repository, I get the following behaviour:

the sliced samples will keep the same autoseek flag value of their source, regardless of the slicer GUI option: if autoseek is enabled on source sample, it will be enabled on destination samples even if the GUI checkbox tells the contrary

this of course is not consistent, I’m going to fix it.

here it is the problem:
on line 154:

  
bDoLoop = value  
  

should be

  
bDoAutoseek = value  
  

I’m going to fix another issue and then release the thing

version 1.1 is now online adding autoseek support and fixing occasional wrong number of slices

IT-Alien: make that a com_renoise_SampleSlicerVERSION.xrnx please…

sorry, done

thanks for updating this It-Alien

now it works as i would like to :yeah:

Hmm, i updated it, but it still creates and maps 9 slices instead of 8. Again, it’s not a real problem, for the last sample is empty.
Some information: The sample is the Amen break (surprise! ;) ) initially synced to 32 lines (but it does the same if i unsync the sample first).
Setup: I sliced it to 8 parts, synced to 4 lines, no loop, no autoseek (there is autoseek, so it’s the correct version).
Result is: 9 samples 00-08 (=9) and 9 mapped keys, up to G#.
I’m using beta2 on Win 7, haven’t tried on my XP machine yet…
However, i can live with that. Thanks again for that tool, saves a lot of work! Mille grazie! :w00t:

edit:typo

grumpf. I will give a look at it again then, sorry

thats weird,i just tried what you described and it works fine here,get 8 slices,im on win xp

I’d better change the whole way the sample creation loop works: currently, it produces samples until the number of frames of the created samples is less than the number of frames of the original samples, but this is prone to rounding errors: it may even be that it actually works on XP while it doesn’t on Seven (haven’t tried it yet).

I should probably change it so that it precalculates the number of slices to create and then create them

I just tested it on my XP machine: same “problem” there…

Will eventually have to figger this Lua thing out myself for personal hackage, but I wouldn’t mind seeing the ability to set a ‘fading offset in ms’ for the beginning and or end portions of slices. This to remove clicks. Great tool as it is now though :)

Sorry to bother you again (esp. because this might not be exactly the right thread for this) IT-Alien,

but i tried, just for fun, to slice the Apache yesterday (4, 8, 16 slices). And guess what, it worked correctly!
Also when i sliced Amen to only 4 slices, everything was fine. But 16 slices produced again 17 samples… :unsure:
I think you’re on the right track, that smells like some sort of rounding error.
Btw, i used those loops “out of the box” (the ones that come with Renoise), so i didn’t use any “exotic samples”.

Might be a missing math.floor() option that might do the trick perhaps?