Add autoseek to Sample Slicer

would it be possible to have autoseek "support"when you use the sample-slicer tool with autoseek enabled,then have the slices you just sliced,also have autoseek enabled,so you dont need/have to go through all your slices enabling autoseek?

hope you know what i mean

Done in a jiffy:

Though with the batch sample property changer, you don’t need to go through each sample to do this.

I will add this to the todo list sir

edit: whoops, I’m too slow for vV… he already did it

i just tried it with the batch sample property changer,and still it not all the slices where autoseek is enabled,even if you choose that in the sample you are converting/slicing

Can you post some instruments and list what process you perform, then i or IT-Alien can have a more closer look at it.
Currently i only added to the existing code in the part where only the “cutted” snippets are processed and get this toggle. It doesn’t touch other samples and it shouldn’t imho.

well what i do is load a sample(i loaded a rammstein track)enabled autoseek,then used the beatslicer tool,and sliced 10 “parts” because i choosed to enable autoseek before i sliced,i would like to have autoseek enabled in all the new slices as well,but they arent,so i need to go through all the slices to enable autoseek

EDIT:i havent tried using this with instruments yet,only samples

I can’t replicate your problem. You know that if you enable autoseek on the sample that you slice before starting the sample-slice tool, the checkbox for this option is being automatically set in the tool as well! (so you don’t need to toggle it in the tool if it is already checked)

ok i have made a small test thingie,try and slice this,and notice that autoseek doesent get enabled to the sliced slices

Are you sure you have downloaded the version from the Xrnx repository in the link i pasted? (I haven’t updated the tool on tools.renoise.com, that is something i leave up to IT-Alien)

Also with your example, i can perfectly slice them with autoseek enabled:
Attachment 987 not found.

for ome reason it wont let me download from the link you pasted,when a press on sampleslicer i only get mainLUA and manifest.xml

when i rightclick i can download the file,but i cant drag n drop??

Autoseek is new, OK, but does it really have to be in the slicer GUI as an option? If I understood things right, all SNS wanted was that the original setting of the sample also gets copied to the slices? This makes sense and can also go without any option.

yes thats excactly what i meant,im sorry if i wasent being clear

I’m sorry, i forgot to mention that the google code site is a source-file repository, there all files are already displayed unpacked (not as xrnx archive but simply displays in their native folder)
You have a “Scripts” folder in your preferences folder (Help -> Show preferences folder) there go to Scripts\Tools\com.renoise.SampleSlicer.xrnx\ and copy the .lua file over there.

You might have to disable and (re)enable the tool in the “Toolbrowser” to allow it reloading the tool though, or enable the scripting-dev option so that you get an extra option in the tools menu called “Reload all tools” see: How To Manually Install Xrnx Files It is a bit more cumbersome method to do it manually, but it works.

ok first off how do i un-associate which program a file should be opened with??

second i cant install the files you updated,for some reason the manifest.xml is a much smaller size than it shows on the website,so when i overwrite the "older"files it wont show the sampleslicer in renoise,and i cant enable or disable it,it just disappears

using the latest version from XRNX repository, I get the following behaviour:

the sliced samples will keep the same autoseek flag value of their source, regardless of the slicer GUI option: if autoseek is enabled on source sample, it will be enabled on destination samples even if the GUI checkbox tells the contrary

this of course is not consistent, I’m going to fix it.

here it is the problem:
on line 154:

  
bDoLoop = value  
  

should be

  
bDoAutoseek = value  
  

I’m going to fix another issue and then release the thing

version 1.1 is now online adding autoseek support and fixing occasional wrong number of slices

IT-Alien: make that a com_renoise_SampleSlicerVERSION.xrnx please…

sorry, done

thanks for updating this It-Alien

now it works as i would like to :yeah:

Hmm, i updated it, but it still creates and maps 9 slices instead of 8. Again, it’s not a real problem, for the last sample is empty.
Some information: The sample is the Amen break (surprise! ;) ) initially synced to 32 lines (but it does the same if i unsync the sample first).
Setup: I sliced it to 8 parts, synced to 4 lines, no loop, no autoseek (there is autoseek, so it’s the correct version).
Result is: 9 samples 00-08 (=9) and 9 mapped keys, up to G#.
I’m using beta2 on Win 7, haven’t tried on my XP machine yet…
However, i can live with that. Thanks again for that tool, saves a lot of work! Mille grazie! :w00t:

edit:typo