ALSA RealTime Priority thread


I recently installed Linux Mint 21 and re-downloaded Renoise. On startup I keep getting this error:

Failed to create a RealTime priority thread for ALSA. Will create a non RT thread instead...

It is highly recommended to use RealTime priority audio threads with ALSA AND Jack to get acceptable audio latencies, but you may need admin rights to create RT threads. Please see the Renoise for Linux FAQ on for more details.

I tried the fix on the FAQ, which says to edit /etc/security/limits.conf, but that fix doesn’t work. I couldn’t find any other fixes anywhere.

I also can’t hear any audio from Renoise, and changing the audio output gives me:

Failed to open the ALSA device 'hw:PCH,0 (ALC255 Analog)' (Device or resource busy).


looks like a mess between renoise/jack/alsa/pulseaudio…

The realtime thread for alsa is not your mute problem’s origin, have you tried to add your user to audio group ?

Are you using jack ?

I added my user to the audio group, the audio came back on but it’s crackly, and I still get the RealTime priority thread message.

I have not on my pc but on laptop it does the same things as you

only thing i can think of is install jack ?

sudo gpasswd realtime -a user

i type this command and install realtime priviliges and it work

and reboot

The /etc/security/limits.conf fix did, in fact, work. I just got impatient and didn’t reboot before trying it again. Whoops.

Update: still getting the crackling issue, it worked for a bit then went back to being choppy. No idea what changed. Seems to only happen with ALSA, Jack is fine.

Jack doesn’t let other programs play audio, and I’d like for other applications to play audio while Renoise is open.

Got this error while trying to do that:

Failure: Module initialization failed
Sink jack_out does not exist.

Actually, installing qjackctl and pulseaudio-module-jack stopped every other media source from playing.

Okay I’ll try to fix it with you. Sorry, I have only experience with Ubuntu, not with Linux Mint, but they are similar.

When I use ubuntu, I think I just needed to install pulseaudio-module-jack and then it worked. It works like, normally I run my pc without jack, just with pulseaudio. But when I start jack with qjackcontrol, all output is automatically routed to jack, and I can even mess with it there and connect apps. Then when I stop jack, everything is back to normal. Sometimes the routings get messed up, then the program “pavucontrol” allows to reset the routings. I.e. the first time starting jack, I needed to select the jack sink after jack was running.

Is the sound back after restarting the system? If not, can you check the settings in pavucontrol in the output devices.

I had to uninstall the programs for the sound to come back on reboot.

Okay, let’s try step by step. Sorry, I’m not so into mint, and there seems to be little info specifically for it on the web.

First let’s check if the system uses pulseaudio. in terminal ps -C pulseaudio. If it outputs something, then pulseaudio is running.

If it is running, try to install “pavucontrol”, it should make an app “pulseaudio volume control” available, this you might need to use to get back the sound if it is lost. Try to start it, but don’t change things yet.

Then install “qjackctl” and try if you can get jack running with it, and if you can get sound in renoise with it. You need to first config and start the server with the “play” butten in qjack, to get it running, and then when you’re ready you need to stop it to get the normal sound back. This we’ll try to fix later. If it crackles, we can try to ensure realtime priorities or make fixes to the cpu scaling to see if it can get better.

Once that is all proper and running, try to install “pulseaudio-module-jack”. restart the system. Make sure that in the qjack settings the options for the “DBUS” interface are enabled. Enter pactl load-module module-jack-sink;pactl load-module module-jack-source;pacmd set-default-sink jack_out in terminal. Start the jack server. Load the pavucontrol app to see if the output devices are muted or not.

If it works, you can make the entry in the qjack startup script or a system file so that the pulse/jack bridge modules get automatically loaded.

1 Like

I have to suggest, is it possible to install Pipewire in Mint and test if you have the same issue? (replaces Pulseaudio and Jack, I think there might be pipewire-* packages for Jack and Pulseaudio) Maybe it’s a simple fix for your issue.

Pipewire is already installed, no idea how to set it up though.

Not sure where the DBUS interface options are in QjackCtl.

Ah okay I see now, there is a new audio subsystem “pipewire”. Is it in use in mint 21 by standard, is enabled and that is why the pulse/jack bridge fails? If it is in use, I have no clue currently what to do about it…I’m driving pulse&jack since years…damn, now I need to learn about another interface…

The dbus options in qjackctl should be enabled by default, in the settings the rightmost “misc” tab

Do I also need to check “Enable JACK D-Bus interface”?

Yes, if your system is set up with pulseaudio and not pipewire, then both dbus options should be enabled. Pulseaudio needs it to sense if jack is running