Automation Bug?

It seems that the automation in Renoise 3.2.1 isn’t working right. It’s not possible to get 2 points on the same vertical line. For example…

This is how it looks if you don’t zoom in:

This is how it looks with maximum zoom:
As you can see it’s not possible to get the right point below the left point on the same position 4. It’s on position 4.01, which is the closest you can get, but it only can happen if you zoom in to the maximum. The less you zoom in, the less close the right point can be set to position 4. If you don’t zoom, the right point can only be set on position 5. Very annoying.

In Renoise 2.7.1 this was not the case, everything worked right.
What happened? Can it be fixed? What can I do?

Or is this another bug which nobody noticed like this one? Will it be fixed with the next update? Would be great!

The automation points have an accuracy of 1/256th of a pattern line.

You’re right that it’s not possible to get two points on the same exact place, as you said, but…

Can you honestly tell me… does it actually matter? :slight_smile:

In previous versions of Renoise, I can assure you that things were being processed in the same way. (Actually less accurately if we go way back…)

In short: Can you actually hear (and/or render) any difference, or is it just a visual difference?


Yep, you’re right - can’t do it using the ‘lines’. Switch to ‘points’. It’s a visual thing, really. But, to me, since it’s visual, the ‘points’ method seems to be sharper. More of an on/off switch.


Can you provide an example of this? As far as I’m aware this has never been possible (how would you even know which point should be used to draw the graph or run the automation?).


Can you honestly tell me… does it actually matter?

Not the fact that you can set the points only 0.01 positions close to each other without being on the same vertical line. But if you have to zoom in every time to get this point that close, then the workflow lacks a lot. In Renoise 2.7.1 you didn’t need to zoom in for getting the points in the desired position. In Renoise 2.7.1 it looks like in the first picture without zooming in when you set the points. In Renoise 3.2.1 it’s not possible anymore, without zooming in you have a distance of not less than 1.0 position between the two points. It doesn’t make any sense using the automation when creating a complex automation requires zooming in and out all the time. It’s frustrating and a waste of time, like the other bug I mentioned (duplicating a VST within the instrument selector). In these two cases the workflow is gone. I hope these two things will be fixed in future, so that it works as good as in the previous versions of Renoise. :neutral_face:

The GIF shows exactly how it is. But as I wrote, in Renoise 2.7.1 you didn’t need to zoom in to get a result like in the first picture. This result would be absolutely ok, even if the points are not set exactly on the same vertical line with a distance of 0.01 positions.

I should have put in a screenshot, here’s what I was saying. This is a very ‘snap to grid’ feature, and you can set it as exacting as you’d like by expanding the External Editor. There’s no angled lines, it’s just points. I also captured the visual above the envelope for you to see the sheer/steep cut. This works in the main volume areas as well.

Screen Shot 2020-07-04 at 5.42.58 AM

The .gif was made in version 2.7.2. It’s impossible to get 2 points onto one line.

OK, I think I understand this now: turn off Snap.

You’ll be able to move the points around without them snapping to the Grid/Lines/Beats. You probably didn’t zoom in before and just assumed they were on the same line, when they were actually 1/256th of a line apart. Nothing about this has changed since its introduction in 2.7.

I believe you, maybe it’s not possible to set the points exactly on the same line. But that’s not really the point. The point is, that you have to zoom in to get these points as close to each other as possible, which wasn’t the case in Renoise 2.7.1. In Renoise 2.7.1 you can get a result like this without zooming in:

In the current Renoise version you have to zoom in to the maximum to get a result like this, which is inconvenient and time consuming at the same time.

OK, I think I understand this now: turn off Snap .

Man, I think that’s it. Thanks, it worked! :grinning:

@ Neuro… No Neuro
Thanks, I will try this out. Maybe it turns out to be better in some cases doing it this way.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.