[BUG] Volume Column - 3.4.1

Video :

Sorry for the low volume of my mic, here the explanation:

BUG: When change the VOLUME in the VOLUME COLUMN it kills the sample.

Important to know, this is a old track from 2008 which I’m porting to 3.4.1 to do some tweeks to render and master for release, it’s was working PERFECT in the old versions of Renoise.

Back to the bug…

The first exemple show working fine when keeps the same values, but when it changes simply kills the wave as you can see.

In the other exemple with the vocals (sorry that I take a little time to figure out, I did this track in 2008 and was remembering how I did)

I have 2 takes in this case, 1 it’s a full verse take with a not so good start, then I have another take with just the start of that verse.

So I keep the original take starting as VOLUME 00 at the same time I start the other take with VOLUME 80 in other track, so when the other take ends, I set the VOLUME to 80 at the full take and keeps until the end of that verse.

But in that case, the full take never starts, which is wrong. If I try to do a fade in didn’t work as well.

So there’s a bug in the volume column which is not working right.

  1. when change the volume kills the sample
  2. if start with 00 never starts

Please fix ASAP.


PS: I already know how to have the same result in other ways, but I don’t want to change several of my tracks again, since I already did that to OF0 works which stopped since 3.0.0.

In other song simply stops without change the volume, just because I’m using in one track/sample, but in the other track with SAME FX but with other sample works fine.

Checked the samples, and the only difference are these, and ALL samples are like the one that didn’t work, that only one different is the LAST sample of the list, and the only working. Maybe the bug is something related to that too.

NOT working - All samples are like that:

WORKING - Only the LAST sample of the list are like that

I can’t change ANY sample to that as I tryed, if this is the problem how to change? Anything I select I don’t get the same result.

Your presentation is very confusing. Nevertheless I don’t think this is a bug in terms of the volume column. As you can see on the first picture “Instrument Presets” and “Sample Presets” are “greyed out” and inactive. It’s like there’s no sample loaded. So it seems that Renoise cannot detect the samples that aren’t working for whatever reason. The question is: What kind of samples don’t work if you change the volume below 80, is it xrni, mp3, wav or something else? Have you already tried to save and reload them?

all samples are wave files, these are old songs prior 3.0.1 working perfect in past versions.

I just opened in 3.4.1 and trying to update them, simple as that.

I will try to save/reload these samples to see what’s happens.

but anyway, Renoise should open them without problems no?

also is not starting a sample with volume 00, take a look in the samples bank, blinked as loaded but is cut just in the next line.

Well, I cannot look into your computer, so I can’t say for sure what’s going on. Yes, of course Renoise should open any wav sample without problems. But I don’t think Renoise is the problem here, because all my old songs made in Renoise 2.7.1 work perfectly in any version of Renoise 3. All samples are getting detected and work fine, there are no greyed out panels or whatever. And I think this is crucial here. Your samples don’t work properly because there’s something wrong in terms of the detection. The question is why. I would investigate in this direction. There is no bug in terms of the volume column. Maybe someone else can tell you more. Good luck.

I made some tests and found out 2 things:
Video :

  1. The error in the Sample is not related to the Volume Column bug, to fix is just add/remove them, but will not fix the volume column.

  2. Any sample with volume column set to 00 followed by nothing is killing the sample

Is that not the intended behavior? 00 = no volume/velocity = silence

Perhaps I misunderstand the issue

1 Like

there’s 3 problems in this thread to be exact:

  1. if you set the volume column to 00 followed by nothing kills the sample, when was supposed to just turn down the volume.

  2. using Volume Slide Down FX seams to cause the same problem as #1, I supposed to sometimes reach the 00 Volume then kills the sample, that’s why in the first song I posted worked with 80 and not with 70, probably with 70 reaches at 00 at some point while with 80 not.

  3. Old songs loaded into 3.4.1 appears with the samples as show in the pics, but did NOT affect in anything, I was just thinking that might be the cause of the bug, but like I show in the 2nd video, is not related at all, was just coincidence.

About your question:

Volume Column is to control Volume levels only, not kills the sample, to kills a sample we use OFF
So in the first video I had a full vocals take, but I didn’t liked the start, so we did another take recording just the start line.

So I start the original take with Volume Column 00 toguether with the new take with full volume, then will play the new take at the start, then just change the volume to 80 on the right moment to keep playing the first take. Like an Envelope/Automation.

Without that, I will need to cut the first sample with the vocal take, and have the work to start right there in the very right spot of the song, something little difficult to do with trackers, work that I already did in the start of this sample. Or start right in that spot using the FX to trigger the same far ahead, since is a long sample, dunno if is in range of the FX. There’s other ways to fix that, but is not the case, the bug exist.

The other problem is caused at Volume Slide Down FX which supposed to vary the volume to give that effect, but when is low enough to reach zero (I think it is) trigger the bug in the volume column to kill the sample, instead of just set the volume to zero.

Before version 3, we don’t need to add anything to volume column to this FX works, dunno why started to be mandatory, doesn’t make sense either, since no value means 80 (max).

Maybe I’m too old and the only one working without the Piano Roll these days. :smiley:


As I said, I don’t think this is a bug in the volume column. If this would be a bug, then every (wave) sample should be affected, right? I still think the problem is sample related. All I can say is that in my case any sample in any old song that was made in Renoise 2 works fine in any version of Renoise 3. Now I’m curious what happens if you save and reload the sample just like suggested, which is something different than copy and paste. If the problem still exists try to switch samples, try different samples, try to decrease the fade out pattern effect or whatever. Unfortunately I can’t tell you more.

His problem is that specific loop samples stop looping if there’s a value of 0 in the volume column followed by an empty value. It’s like a note off and a fast release. Usually a loop should never stop looping until there’s a note off or another note. A loop should work if there’s volume 0 at position 00 followed by volume 40 at position 04 just like on this picture.
There should be no sound from position 00 to 03 and sound again at position 04.

@TNT forget about the sample, happens to ANY sample. Please watch 2nd video.


I did, that’s why I know that you copied and pasted a specific sample (number 13 I think) to show the issue, but you didn’t try what happens if you save and reload it. And when you say “happens to ANY sample” you’re talking about any sample (except the one that doesn’t have greyed out Instrument Preset and Sample Preset panels) of THAT ONE specific song made in a prior Renoise version, right? It doesn’t happen to ANY sample in general, right? In case it would happen to any sample in general, then it’s not because there’s a bug in the volume column or because of Renoise. Personally I cannot confirm having these kind of problems in Renoise 3.4.1.

I don’t have the issue of value 00 killing the sample .
Can you upload an xrns ( with just one sample )in which the bug occurs ?

Ok, this videos shows it’s not the sample.
Video 3 :

Works fine in a brand new song. The problem is when loading an old song into Renoise 3.4.1.
track behavior is different? or sample behavior? do I need to check or uncheck something to behave as suppose to?

I don’t know what is causing this, but if I load an old song and doesn’t work it’s a bug.
The song works great in the old versions of course, this song were released in 2004.
It’s happening to ALL my songs, not this one. I used 2 different in these videos.

works fine with a brand new song, the problem it’s only loading old tracks.

I will do that right now and upload for testing.

Ok, here the video making these files:

Here the files:

hope you can ID the error and fix ASAP.


No, it’s not! Even this doesn’t work in your old song:
There’s no sound at position 4.

I’m pretty sure this is a compatibility issue! It seems that you’ve made those songs with a VERY old Renoise version. Look, usually there’s BPM, LPB and so on, just like that:
When it’s like that, everything works fine, even all your old samples with all your pattern effects, and there is no volume issue at all.

But when I load your old song that you’ve provided it’s like that:
Instead of LPB there’s SPD. And that’s causing the issue!

What’s the version that you’ve created your songs with? Renoise 1? Even in Renoise 2 (at least in 2.7) there’s LPB and not SPD: There’s no way to fix this. It’s like you want to run a PS1 game on a PS5, and that’s not gonna happen. So I’m afraid there are only a couple of options what you can do:

  1. Use the old Renoise version that you used for creating your old songs (= best option for sure)
  2. Open 2 instances A and B of a current Renoise version, load your old song into instance A and copy and paste every single instrument from instance A to B first, afterwards copy and paste all the patterns from instance A to B, then save your song in instance B

That’s all you can do. Unless a coder could do some magic, but I don’t think so.

It sounds to me like this could be an instrument problem or playback compatibility problem, try updating your instrument and check the song options.

I agree, not a bug at all
When loading old songs , click song options and upgrade to latest veresion …
The upgrade button is there to make it compatible


Cool, you got it! I didn’t know about that option in case of loading old songs, I never had to load that old songs. Usually it looks like this:
There is no compatibility option. So you’re the magician at this point - without coding. :slightly_smiling_face:
Confirmed, it works. That’s the solution for @hajas .
This way it can also happen that not everything sounds 100% original. But that’s usually the price you have to pay for converting things instead of using the original software. But it seems to work fine here.

1 Like

Thank you! Didn’t knew about that! Will try that ASAP!