Buggy Instrument Slot

I’m working on a project, and need help to fix a buggy file. (running 2.6 on windows XP sp2)

  • the song was originally conceived with Renoise 2.5
  • last week i decided to continue it, this time of coz with 2.6 :)
  • i did some editing, saved the song with a new file name and all was good

Then weird stuff started happening; each time i try to shut down renoise after working on this project, or start a new song, renoise and windows freezes - totally.
it saves a backup file, but it still can’t manage recover when i restart renoise, although the project saves correctly, i can just reload the file and continue working, everything seems fine with the file.

So even if this was not a total showstopper for me, it’s still really irritating and i thought i should report it, maybe it’s a 2.6 bug?

anyway i started debugging a little myself, and it all boils down to instrument slot “3”, which holds the vsti “Drumatic 3”. the same freeze happens if i try to move this instrument up/down, or insert a new one before it. if i delete or clear the instrument, the bug is gone as well. i then tried to insert a copy of drumatic in slot 4, remap the notes, and delete slot 3, but no go.

and it does NOT seem to be Drumatic 3 that’s the problem. if I start a new project and use it there, there’s no bugs whatsoever, neither in renoise 2.5 or 2.6.

to me it seems it’s this particular XML that’s struggling here.
hope this bug can be found and fixed.
Here’s the file:
Here’s the file
(btw, this is a stripped-down version, containing only the drumatic track).

temporary workaround for me while working on this song is to save changes, and then manually terminating renoise in Task Manager instead of closing it down properly :)

Any ideas?

Try using the search-phrase “Drumatic” on the Renoise forum and select “Any date and older”.
I have seen other problem-reports involving the Drumatic plugin.

ok, thanks for the tip ;)
hm yes it seems drumatic v3 can be buggy when LFO is used to control its parameters, instead of “manual” automation.
i’ll double check this and see if that’s the case with my song as well.


which version of drumatic are you using? Tried to replicate this with Drumatic 1.01 on Vista here, but it worked fine so far.

Does unloading Drumatic (select “None” as VSTi) then reloading a clean drumatic VSTi instance solve this problem? Maybe the Drumatic preset somewhat got broken and freezes the plugin when unloaded.

hi, i’m using Drumatic v3
(more specifically 3.02, i think)

And today i tried the following (as suggested in this thread):
disabling LFO automation and automate manually instead = and voila, all bugs and problems solved :)
but isn’t it weird that it can’t handle the lfo?

earlier I tried unloading & reloading the plugin, but it didnt make any difference. also tried changing slot, remapping notes and so on, but i couldnt get rid of the problem in any other way.

so, I assume the source of this bug is drumatic, and not Renoise. Right?

Yes, it seems so. Could replicate this here finally after updating my Drumatic version and retrying this a few times. Its Drumatic which freezes here, not Renoise.