Can I hear entered notes when the song is playing?

When I’m editing a pattern I can hear the notes as I enter them using the keyboard, but when the song is playing, they don’t play as I enter them.

If I enable follow mode, the notes play as I enter them – but this feels completely out of control. I hit the notes on the wrong rows and have to go back and edit. By that time who knows what I actually meant to enter? Not me.

So, with follow mode off, I’d like to play the song and hear notes as I enter them. I just can’t find a way to do this.

The reason for this is that I don’t want to interrupt the playback, because I want to decide what notes to enter based on what I’m hearing and how the song feels, and I only know that when it’s playing. When it stops I lose the place.

In the old days in Impulse Tracker I used to keep the pattern looping and enter the notes just behind the playback cursor. This helps me see where I am in the pattern and editing becomes something between playing live and composing. It sounds horrible while you’re entering the notes but it’s great when it loops back round and everything resolves perfectly into place. Also you can race the play cursor and write the part in one loop and this feels somehow like winning. Playing live and then editing feels like admin, I have to tell you.

I’ve tried Renoise a few times over the years and it’s great. I put some time into learning its ways and forgetting my 90s habits, but I’ve finally realised that this quirk is what’s stopping me getting further than putting a few ideas down. If I could get this one thing to work it would be huge. Everything would be perfect. I absolutely promise you the album I’d make would be monstrous.

How do I do it!?

Are you using a USB alphanumeric keyboard or a MIDI keyboard? Are you using a tool with OSC?

If it is a USB alphanumeric keyboard, make sure you have this setting correctly:
Disable it if you have problems.

If it is a MIDI keyboard, make sure you have this setting correctly:
Disable it if you have problems.

For live recording, you can use the quantization to better fit the notes:

Whenever you record a note, it should sound, within track type. Make sure the problem does not come from any part of the native instrument. What kind of instrument do you use? Is it a native instrument with samples or is it a VSTi plugin?

Hi Raul. Thanks for replying.

I’ve tried a USB alphanumeric keyboard and a MIDI keyboard. I’m following your screenshots and I can see that the velocity is non-zero on the notes I’m entering. When I play the pattern back, I do hear the notes – so I don’t think this is a velocity problem.

So the sound works. My problem is that I would like to hear the notes at the moment I enter them, on top of the song. I guess this is a slightly unusual way to do it.

Thanks for pointing to the quantization. I hadn’t tried it and It does help, but it’s still not quite what I’m looking for. I guess I could slow the tempo right down to make it easier still.

That’s done on purpose, so you can enter notes while playing back a song Live, without disrupting the already playing notes. To hear the entered notes, you either need to stop the song, enable pattern following or disable editing.

Regarding what @taktik mentions, here are a couple more details that can help you.
The notes will not jump to the next note column (more to the right) while you have released the key that triggers the note. It is the absence of the note Off that causes this jump. So,

  1. Be sure to release all the keys before stopping the song. Otherwise, when not recording the last note Off, will result in the jump to another adjacent note column, and this confuses the user at the time to start recording again (at least me). To force record again from the first note column, press the “Stop playing” button again (with the song stopped).

  2. If you are not interested in recording “note Offs”, disable this:
    Thus, the notes will accumulate in the first note column as long as you do not press two or more keys at the same time while playing a line. In this case, the notes will be cut between them, if the NNA is not activated in “Continue” in all samples of the instrument you enter.

@Raul that makes perfect sense and actually sometimes this behaviour is exactly what I would want too.

I would still love it to be an option to hear the notes as you enter them though. I guess I can ask and hope, but I think maybe nobody else wants this :smile:

@taktik thanks. I didn’t get how this worked. The jumping notes definitely add to my sense of confusion. I’ll do as you suggest to help keep it under control.

Also now I’ve finally bought Renoise and can get low latency I can be much more accurate when I’m playing notes in. I’ll see if I can change my habits and get live recording to work for me.

Thank you both for your advice.

You probably are in the same track that is playing back when you press notes. Try creating a new track, empty of notes, and play notes IN this track while the song is playing. if that makes sense. If you are in a track that is playing written notes, then you can only play in between the written notes. Renoise is reading both the written and what you play live on the keyboard at the same time, so when a written note starts, your live notes stop.

Yeah, IMHO this sucks. It should jump back to the column where you originally placed the cursor to, no matter if releasing the keys before record-stop or not.

From my experience with this, I think the composer should be aware that he should not stop the live recording until he stops all the notes. Otherwise, he are making “an incomplete recording”. Recording notes involves shooting notes and shutdown notes, both.

However, it would be easier if you automatically record from where the cursor is, regardless of whether or not there are note-Offs. But the composer must be aware that something strange has been done here that he will need to fix (probably add note-Offs afterwards manually).

Another way to avoid this situation would be that, when stopping playback for live recording, Renoise will automatically record missing note-Offs to stop all the notes. Maybe this would be the most appropriate way. But this should be discussed with @taktik, in case he wanted to change it.

@andrew. I don’t know if you’re still confused. But you cannot record notes while song playback is activated without the follow the player. Playback must scroll through the lines to deposit the notes. Renoise works perfectly here, even recording delay parameters. It’s just a matter of getting used to it.

If you simply want to play while listening, disable the edit mode. You will not record, but you will listen to what you play while the song is running.

If you have latency problems (if you use a MIDI controller), follow these tips: About latency device settings

@Raul true, you can’t record, but you can enter notes by hand when the song is playing. You just don’t hear them, but that’s for the very good reason that @taktik mentioned.

Any other time you enter or play a note in Renoise, you hear it. That apparent inconsistency confused me but I get the reasoning now.

It’s kind of hard to explain, but my process in Impulse Tracker many years ago was like: listen, edit, loop, listen, edit, loop, listen, edit, loop… and I’d just keep the track going. I could switch through instruments, enter a note, hear it to sense check, let it loop round to hear the whole thing in context, and move on. This was super quick for me. You could compare it to moving midi notes around in something like Reaper. You hear new midi notes that you enter or edit while the track’s playing.

This isn’t really like live recording. It’s more a process of building up each track iteratively. If I’m going to be making 10 or 20 revisions to a column of notes, live recording isn’t really an option. I don’t want to record notes, wait for the cursor, play one note, wait…

Anyway, I think I can get close to what I want by getting used to jumping in and out of edit mode while the track is playing. It’s a few more keystrokes but I’m sure I can live with it.

Latency is great now, I just needed to pay up and get ASIO working :smile:

I understand what you mean. You made me remember when I used Impulse Tracker myself (I started with it).

I think that if you get used to activating / deactivating the switch to continue playback, you may find a closer use.

However, this seems like a specific case not addressed. Maybe there could be an option that allows you to enter and play the note on the selected line while the playback is on its own.

1 Like