Click/pop during pattern transitions (automating DSP bypass)


I realize there have been many posts about this. However mine is unique, as I’ve dug for hours for an answer to no avail.

I get pops in the transition betwteen patterns, due to the fact that I’m automating the bypass on some native DSP effects on my master. Device is turned on at beginning of pattern. Device is off at end of same pattern to complete my transition, and upon playing the following pattern my master clips from a nasty pop. I have tried altering my audio settings as well as automating the volume with gainer to -INF gain at the moment the pop happens to no avail.

The only relevant advice I can see is in the manual (In the “Graphical Automation” section, regarding tips on smooth pattern transitions. It reads as follows:

“To maintain a smooth envelope between two patterns, simply create a point in the second pattern’s envelope and move it to the beginning of the pattern. Now, as you move the point up/down, it will automatically snap to the waveform of the previous pattern.”

I don’t understand…does this mean having the envelope points cross the pattern’s beginning and end to make the transition more smooth?


abruptly bypassing the DSP’s right before/during pattern transitions causes cracks/pops.

its frustrating the hell out of me and is ruining my cool transition. Please for the love of ALL GODS (and renoise users around the world) help!

-Thousand Thanks!

It can be a bit dangerous to automate the bypassed/active state of devices due to plugin delay compensation (PDC).

Depending on the type of device, and whether you have enabled PDC in the preferences, tracks are re-processed and clicks/pops can appear as a result of this. This is not easily “camouflaged” as it can potentially affect all sound, not just your current track.

Strike that - I was just informed that PDC is in fact maintained with bypassed devices.

The problem is that processed/unprocessed signals can be very different, and crossfading isn’t implemented when changing between states.

So, such clicks can be avoided only by carefully adjusting volume on those critical spots.

Hey danoise, as far as I understood it, the pdc remains even in disabled state (that’s why I requested a third state once).

@jurek: indeed :blush:

@norasu: if you could share the project (via PM or otherwise), I’m sure we could come up with some solution…

Disabling PDC didn’t remove the pops. Dude! This is a maaaajor buzz kill. Thank god some precise gain automation on the master fixed it without ruining the moment, phew! 8)

I’m sorry but why haven’t more people noticed or complained about this? is there any way to patch renoise to fix this?

I would share the project file but my bass track is a 3rd party vsti and I can’t render because I’m in demo mode. I almost spent my last 75 dollars before my last paycheck on renoise but I have to wait until my next one…I’m completely in love. Long time ableton user no more hahaha…well…maybe to mix/master and perform :stuck_out_tongue_winking_eye:

I would share the project file but my bass track is a 3rd party vsti (…)

Which VST plugin is it? We may already have a copy of it, or we can at least test it with the demo version. Otherwise, you could probably swap the bass VST for a similar sample instead?

Which DSP devices are being used?

If you don’t want to share the song in public, you can send the XRNS to us privately at support(at)renoise(dot)com , or maybe you could make us a very simple test XRNS instead and post that here.

Here’s an example… although I think it falls under the category of “processed/unprocessed signals can be very different”. It’s just a LFP toggled on and off.

6223 pops.xrns

Still it would be nice if Renoise made it easier to do this without clicks - it’s kind of tricky to avoid (at least for me…)

Same as this: