Default loop mode for sample

Hi all. I searched around and it seems to be a simple thing, but I didn’t find a thread.

Is there a way to set the default loop mode for a sample to be “Off.” Coming back to Renoise to check out 3.0 and I don’t remember loading samples and they automatically were set to loop “Forward.” It is getting annoying to have to change that for every kick, synth, etc. and I don’t remember doing that in 2.8, though when I go back to 2.8, it seems to do the same thing.


If the instrument and loop settings of the sample are set as of for the sample, they remain off. If you load a new sample the default state is off.
I’m not getting the issue you have.

If the loop mode gets enabled when you load a sample, then either the sample itself has a loop stored within it, or you might have installed a Lua tool which is somehow setting this loop every time you load a sample?

I can’t think of any such tools at the moment, so it’s probably just the samples themselves.

You can tell Renoise to ignore imported sample loops if you want to, via the File preferences:

5111 renoise-prefs-file-import-loop.png

If this really annoys you every time, then it might be a better idea to simply fix the samples once and for all. Either re-save them from Renoise with the loop disabled, or use some sample editor or batch processing tool to remove the loops from your whole sample collection.

I didnt know this option exists.
Dblue, is it possible create opposite action (enable loop mode on for every loaded sample) or do you have a tip how tu change loop option of thousand of samples for ever?

I´ve downloaded AWKF samples (hundreds of single cycle waveforms) and i wanna experiment with them but if you load any of them, loop option is off so trying new waves is kinda annoying.

If you’re on Windows, then Wavosaur is a great free sample editor with batch processing. They have some batch edit functions specifically for adding/removing loops.

Audacity is cross-platform, free, and also has batch processing, although I haven’t personally used it for that purpose very much, and I don’t know for sure if it can batch edit sample loops.

Thanks gova and dblue! I disabled all my tools and messed around before posting, so I know it isn’t a tool issue. It is definitely an issue with loop info in the sample file. I think my solution is to have a batch of samples, mainly drum hits, that I’ll copy to a new folder and batch process for use in Renoise. That way if I use them in Live or whatever DAW, it won’t add info. Good to know of the setting in the Files part of the preferences, too. Thanks again all.

thx dblue, will look at audacity as i use it much more than wavosaur…

You can do this with a tool.
I did something similar for a different question. The tool allows you to lock the loopmode for a specific mode. So if you load different samples, the loopmode will be set to the loop that you locked it to: